Unable to Remap Buttons

I assembled my Picade and loaded up Retropie yesterday and have been banging my head against the wall ever since.

No matter how I configure my input in Emulation Station or Retro Arch, my buttons just do what they want anyway. For example, one button on the CP always enables “fast forward,” even if I change the map for that key in the software. The volume keys seem to be hardwired to their function as well, as they don’t seem to be recognized in the software when I try to remap them.
I’ve also been unable to get anything to work for adding credit/coins…

I’m at my wits end with this and about ready to ditch the Picade board entirely. I mean, setting up a gampad is completely painless… Using a few buttons and a joystick shouldn’t cause one to lose one’s hair :-p

I’ve read through forum posts, but haven’t had much luck (obviously). Is there a comprehensive guide to getting buttons mapped how you want them? Any help is greatly appreciated!

1 Like

I had the exact same problem! Are you using a clean RetroPie image or one created by someone else?
I’m pretty certain the problem is unrelated to the Picade board! More of a RetroPie/emulationstation issue!
I ended up just setting the mappings for each emulator whilst in RetroArch! Didn’t take long! And all works perfect now!

I was using a pre-configured image, yes. No matter where I configured the controls (EmuStn, Retroarch or in Mame), the control maps weren’t working.

So, I loaded a clean install of RetroPie and what do you know? The controls work just as advertised!
Well, except the two volume buttons, which only want to do volume. I can live with that, though.

Yeah it’s strange! It seems some pre-made images have issues with keyboard remaps!

Remapping the keys using another keyboard and inside the emulators worked for me but I did have to disable the conflict key mappings like fast forward etc!

If you’re using a newer retail Picade USB PCB you need to update the firmware before the volume controls can be switched to any other mode. (Don’t try this on the older Kickstarter board!)

See: New 2.x Configurable Keyboard/Gamepad Firmware

You will also most likely have to rebind your controls again!

Went thro the same with A preset up image.
The configs are a nightmare to get your head around.
Look at the config for the emu that is giving issues.
“Arcade” was my bugbear…
Search through it for player one bindings, some will be “null” others will be set to keys that we don’t use on picade.
“Null” those out.

For the fast forward search the config for “space” when you find the one which is “fast forward” null that too.

Some more info copied and pasted

Hardcoded Configurations
These configurations are manual edits you can make that are locked to a specific libretro core and controller. Hardcoded controls can be configured either globally, specific to the emulator core, or specific to an individual game.

Config Hierarchy
All RetroArch based emulators can be configured in the following way:

Global settings - that are settings which should apply to all systems - are done in the file:


System-specific settings are done in the files:


So I’m having the same problem in ‘Arcade’ ROMS regarding video record and fast forward. I changed the ‘all’ retroarch.cfg - and the one that sits in the ‘/arcade’ folder - but that still has the same problem. However when I go back into ‘/arcade/retroarch.cfg’ it appears to have reset to the default mapping.

Even more bizarrely - if I rename or delete ‘/arcade/retroarch.cfg’ it gets rebuilt again - with the original configuration.

Anybody have an idea what’s going on? Anyway I can make a change stick? Any help much appreciated.

I don’t like to pass the buck, but I’ve got very limited experience with RetroPie and rely on other forum-goers to fill in those gaps. You might have better luck- if you haven’t solved it already- over on the RetroPie forums: https://retropie.org.uk/forum/

Just to clarify here… If the joystick and console buttons on my Picade Xhat need to be remapped, would that be something I should do with Pimoroni software? Or RetroPie?
Somehow, I got confused during the step when RetroPie quizzed me on all the buttons, around when they asked about the 10th or so, realizing that they wanted me to define more than were on the cabinet. Also, there are no labels on the outside of the Picade. :)
A map like this would help if it was included with the Picade kit: (originally from one of the replies in the mega-thread PICADE - X Hat- Buttons + Joystick not detecting )

My current setup is so bad, it is hard to navigate Emulationstation.

You remap the buttons is via Emulation Station (main menu > configure input). As you realised, you don’t map all the functions when using the X HAT because you haven’t got enough buttons. I mapped the joystick, start, select, A, B, X, Y, left shoulder, right shoulder, and the hotkey.

I mainly play arcade games, and getting the buttons set exactly the way I wanted them was one of the trickier aspects of my custom build using the X HAT. I found the Pimorini key choices difficult to use, so I tweaked the picade.dts file and did a manual install. I now have a consistent setup, for example my bottom left game button is used to select menus and games in Emulation Station, and is also the fire/jump button in arcade games. I also have a button configured as the number 2 so I can start a 2 player arcade game.

1 Like