Unable to Remap Buttons


#1

I assembled my Picade and loaded up Retropie yesterday and have been banging my head against the wall ever since.

No matter how I configure my input in Emulation Station or Retro Arch, my buttons just do what they want anyway. For example, one button on the CP always enables “fast forward,” even if I change the map for that key in the software. The volume keys seem to be hardwired to their function as well, as they don’t seem to be recognized in the software when I try to remap them.
I’ve also been unable to get anything to work for adding credit/coins…

I’m at my wits end with this and about ready to ditch the Picade board entirely. I mean, setting up a gampad is completely painless… Using a few buttons and a joystick shouldn’t cause one to lose one’s hair :-p

I’ve read through forum posts, but haven’t had much luck (obviously). Is there a comprehensive guide to getting buttons mapped how you want them? Any help is greatly appreciated!


#2

I had the exact same problem! Are you using a clean RetroPie image or one created by someone else?
I’m pretty certain the problem is unrelated to the Picade board! More of a RetroPie/emulationstation issue!
I ended up just setting the mappings for each emulator whilst in RetroArch! Didn’t take long! And all works perfect now!


#3

I was using a pre-configured image, yes. No matter where I configured the controls (EmuStn, Retroarch or in Mame), the control maps weren’t working.

So, I loaded a clean install of RetroPie and what do you know? The controls work just as advertised!
Well, except the two volume buttons, which only want to do volume. I can live with that, though.


#4

Yeah it’s strange! It seems some pre-made images have issues with keyboard remaps!

Remapping the keys using another keyboard and inside the emulators worked for me but I did have to disable the conflict key mappings like fast forward etc!


#5

If you’re using a newer retail Picade USB PCB you need to update the firmware before the volume controls can be switched to any other mode. (Don’t try this on the older Kickstarter board!)

See: New 2.x Configurable Keyboard/Gamepad Firmware

You will also most likely have to rebind your controls again!


#6

Went thro the same with A preset up image.
The configs are a nightmare to get your head around.
Look at the config for the emu that is giving issues.
“Arcade” was my bugbear…
Search through it for player one bindings, some will be “null” others will be set to keys that we don’t use on picade.
“Null” those out.

For the fast forward search the config for “space” when you find the one which is “fast forward” null that too.

Some more info copied and pasted

Hardcoded Configurations
These configurations are manual edits you can make that are locked to a specific libretro core and controller. Hardcoded controls can be configured either globally, specific to the emulator core, or specific to an individual game.

Config Hierarchy
All RetroArch based emulators can be configured in the following way:

Global settings - that are settings which should apply to all systems - are done in the file:

/opt/retropie/configs/all/retroarch.cfg
(example)

System-specific settings are done in the files:

/opt/retropie/configs/SYSTEMNAME/retroarch.cfg