[SOLVED]Skywriter Firmware Info error


#1

Brand new Raspberry Pi 2 with the Skywriter Hat

Linux rpihobby01 4.1.13-v7+ #826 SMP PREEMPT Fri Nov 13 20:19:03 GMT 2015 armv7l GNU/Linux

curl -sSL get.pimoroni.com/skywriter | bash
sudo apt-get install python-smbus
sudo reboot

pi@rpihobby01:~ $ sudo i2cdetect -y 1
     0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f
00:          -- -- -- -- -- -- -- -- -- -- -- -- -- 
10: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 
20: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 
30: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 
40: -- -- 42 -- -- -- -- -- -- -- -- -- -- -- -- -- 
50: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 
60: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 
70: -- -- -- -- -- -- -- --             

So I pretty sure that means its all setup, but I did later run raspi-config again and enable SMB Bus and I2c was set enabled

sudo apt-get install python-dev python-xlib libxtst-dev libpng-dev python-pip pd

pi@rpihobby01:~/skywriter-hat-master/python/examples $ sudo ./test.py
Got firmware info

Got firmware info

Got firmware info

...

^CTraceback (most recent call last):
  File "./test.py", line 37, in <module>
    signal.pause()
KeyboardInterrupt
Got firmware info

The … relate to a number of the “Got firmware info” messages repeating

pi@rpihobby01:~/skywriter-hat-master/python/examples $ ./synth.py 

Got firmware info

...

Populating temp PD file: /tmp/tmp1IjZUl

Got firmware info

Got firmware info

...

Got firmware info

Got firmware info

Started PD with PID: 2092
 File: /tmp/tmp1IjZUl
Attempting to connect to PD
Connected to PD
Got firmware info

Got firmware info

...

Got firmware info

Got firmware info

^CTraceback (most recent call last):
  File "./synth.py", line 16, in <module>
    signal.pause()
KeyboardInterrupt
Killing PD instance
 Got firmware info
Removing temp file

Got firmware info

Also the PD example failed

pi@rpihobby01:~/skywriter-hat-master/python/examples $ pd theremin.pd sh: 1: wish: not found
watchdog: signaling pd...
watchdog: signaling pd...
watchdog: signaling pd...
watchdog: signaling pd...
watchdog: signaling pd...
watchdog: signaling pd...
^CPd: signal 2

and nothing was displayed in an additional windows

tried a pip manual install

sudo pip install skywriter
Requirement already satisfied (use --upgrade to upgrade): skywriter in /usr/local/lib/python2.7/dist-packages
Cleaning up...

but it is not interested

tried a full manual install

git clone https://github.com/pimoroni/skywriter-hat
cd skywriter-hat/python/library
sudo python setup.py install

but resulted in the same “Get firmware info” messages

cloned the besherman pull request branch

pi@rpihobby01:~ $ mkdir tmp
pi@rpihobby01:~ $ cd tmp
pi@rpihobby01:~/tmp $ git clone https://github.com/besherman/skywriter-hat.git
Cloning into 'skywriter-hat'...
remote: Counting objects: 236, done.
remote: Total 236 (delta 0), reused 0 (delta 0), pack-reused 236
Receiving objects: 100% (236/236), 1.99 MiB | 1.00 MiB/s, done.
Resolving deltas: 100% (88/88), done.
Checking connectivity... done.
pi@rpihobby01:~/tmp $ cd skywriter-hat/python/library/
pi@rpihobby01:~/tmp/skywriter-hat/python/library $ sudo python setup.py install
running install
running bdist_egg
running egg_info
creating skywriter.egg-info
writing requirements to skywriter.egg-info/requires.txt
writing skywriter.egg-info/PKG-INFO
writing top-level names to skywriter.egg-info/top_level.txt
writing dependency_links to skywriter.egg-info/dependency_links.txt
writing manifest file 'skywriter.egg-info/SOURCES.txt'
reading manifest file 'skywriter.egg-info/SOURCES.txt'
reading manifest template 'MANIFEST.in'
writing manifest file 'skywriter.egg-info/SOURCES.txt'
installing library code to build/bdist.linux-armv7l/egg
running install_lib
running build_py
creating build
creating build/lib.linux-armv7l-2.7
copying skywriter.py -> build/lib.linux-armv7l-2.7
creating build/bdist.linux-armv7l
creating build/bdist.linux-armv7l/egg
copying build/lib.linux-armv7l-2.7/skywriter.py -> build/bdist.linux-armv7l/egg
byte-compiling build/bdist.linux-armv7l/egg/skywriter.py to skywriter.pyc
creating build/bdist.linux-armv7l/egg/EGG-INFO
copying skywriter.egg-info/PKG-INFO -> build/bdist.linux-armv7l/egg/EGG-INFO
copying skywriter.egg-info/SOURCES.txt -> build/bdist.linux-armv7l/egg/EGG-INFO
copying skywriter.egg-info/dependency_links.txt -> build/bdist.linux-armv7l/egg/EGG-INFO
copying skywriter.egg-info/requires.txt -> build/bdist.linux-armv7l/egg/EGG-INFO
copying skywriter.egg-info/top_level.txt -> build/bdist.linux-armv7l/egg/EGG-INFO
zip_safe flag not set; analyzing archive contents...
creating dist
creating 'dist/skywriter-0.0.2-py2.7.egg' and adding 'build/bdist.linux-armv7l/egg' to it
removing 'build/bdist.linux-armv7l/egg' (and everything under it)
Processing skywriter-0.0.2-py2.7.egg
Removing /usr/local/lib/python2.7/dist-packages/skywriter-0.0.2-py2.7.egg
Copying skywriter-0.0.2-py2.7.egg to /usr/local/lib/python2.7/dist-packages
skywriter 0.0.2 is already the active version in easy-install.pth

Installed /usr/local/lib/python2.7/dist-packages/skywriter-0.0.2-py2.7.egg
Processing dependencies for skywriter==0.0.2
Searching for smbus==1.1
Best match: smbus 1.1
smbus 1.1 is already the active version in easy-install.pth

Using /usr/lib/python2.7/dist-packages
Finished processing dependencies for skywriter==0.0.2
pi@rpihobby01:~/tmp/skywriter-hat/python/library $ cd ../examples/
pi@rpihobby01:~/tmp/skywriter-hat/python/examples $ ./test.py 
Got firmware info

Exception in thread Thread-1:
Traceback (most recent call last):
  File "/usr/lib/python2.7/threading.py", line 810, in __bootstrap_inner
    self.run()
  File "build/bdist.linux-armv7l/egg/skywriter.py", line 103, in run
    if self.todo() == False:
  File "build/bdist.linux-armv7l/egg/skywriter.py", line 332, in _do_poll
    handle_firmware_info(data)
  File "build/bdist.linux-armv7l/egg/skywriter.py", line 289, in handle_firmware_info
    raise Exception("No valid GestIC Library could be located")
Exception: No valid GestIC Library could be located

^CTraceback (most recent call last):
  File "./test.py", line 37, in <module>
    signal.pause()
KeyboardInterrupt

what can I do next?


[RESOLVED]Skywriter theremin.pd demo does not work
#2

I found this issue on github
github.com/pimoroni/skywriter-hat/issues/7

but its closed.

How do I refresh the firmware on the skywriter HAT ?


#3

Sorry for not getting back to you sooner, I’ll find the instructions package I put together and get it over to you!


#4

my new skywriter hat doesn’t work ,is it possible to redo the firmware , TY


#5

You can try: the firmware files are available in the Skywriter HAT repository here: https://github.com/pimoroni/skywriter-hat/tree/master/firmware

Plug in your Skywriter HAT and then:

git clone https://github.com/pimoroni/skywriter-hat
cd firmware
sudo python ./update.py

(Don’t do this on a full-sized Skywriter!)


#6

finally got a chance to try this ,fairly new to Linux ,so bare with me ,I followed to the letter , when I try to run update.py .it gives an error .
"type yes to continue ,did that and got this error .
"trackback(most recent call last ):
file “./update.py” .line 116, in
if not input()==“yes”:
File ",line 1, in module,
name error ,name ‘yes’ is not defined

when I run the test .py and run mi finger over the writer I get a bunch of numbers on the screen .
if I run other file in examples I ger no such file ,error
I’m using ssh to do all this

thank


#7

D’oh! I’m sorry, it must be sudo python3 ./update.py


#8

ok, i’ll try that ,later thanks


#9

ok, it works now thanks so much for your help …,.edit , I got the pdtone.py to work , when I try others I get errors .
when I run keyboard.py I get "trackback [most recent call last]:
file “/home/pi/pimoroni/skuwriter/examples/keyboard.py” , line 4, in
import autopy
importError: no module named autopy’


#10

That usually means you’re missing a Python module- in this case autopy- which you should install with:

sudo apt install python-dev
sudo pip install autopy

#11

ok I will try that later today ,thanks


#12

finally got a chance to try installing autopy , get an error trying to do install sudo pip instal autopy .

it dose a bit and then gives error .

this is the error .
complication terminated .
error:cammand ‘arm-Linux-gnueabihf-gcc’ failed with exit status 1

thank you for taking the time to help


#13

autopy is a pain to compile/install - in large part why our installer is not trying to roll it out.

You need to post the entire context of the error and we may be able to figure it out together, but please use copy/pasting and don’t pick and choose what you think is relevant when posting an error, this can only lead to erroneous diagnostics or wild guesses.


#14

Hi there @gadgetoid! Could you please link us to the latest firmware for the Skywriter XL? We’ve been getting a GestIC Library/firmware failed update error.


#15

There’s no latest version, since it hasn’t changed since launch, but the firmware that Skywriter ships with can be found here: http://get.pimoroni.com/skywriter-fw.tgz

Warning: Do not attempt to flash this to a Skywriter HAT.