Sparkfun 2D scanner not scanning

Hi all, I have a SparkFun 2D Barcode Scanner Breakout. When plugging it into any PC it initialises just fine (light comes on and it beeps) but that’s it. I can’t get it to scan any barcode. I tried USB-COM as recommended but then tried others and also under different lighting conditions as well as printed and on-screen. So I am stuck. Does anybody have any troubleshooting advice for me, please? (I did have had a look at the YouTube video and the manual, but no joy).

When I press the trigger button the LED and laser both come on and cuts off again after 8s as standard, so functioning looks like it does on the YouTube video but no barcodes get scanned no matter how close or far away I go with the scanner.


I’ve not used one of these, for support you might get a faster answer on Sparkfun’s forum? Or email

If you open the Settings Manual link on the product page it gives you a PDF including a “Reset to factory defaults” barcode, it might be worth trying that?

Hi Shoe,

Thanks yes I have emailed them and contacted the supplier. I have tried the “restore to default code” too, but also with no joy, unfortunately. If I do find a resolution though I will post it here since there doesn’t seem to be any other posts on this issue.