SpeakerPhat hitting Pi3 heat sink, need to revert ALSA script


#1

Blokes, when I purchased the Speakerphat (supposedly compatible with the Pi3), I didn’t realize that the speaker would hit the Pi3’s heat sink, preventing a comfortable installation. Is there a spacer/riser necessary to elevate it? Also, how do I revert back to using the Pi’s on-board audio chip after running the Speakerphat ALSA install script? Any help would be appreciated.


#2

I would use a Mini Black Hacker personally, but one of those (11mm) would work too.

to re-enable on-board audio:

curl https://get.pimoroni.com/audio | bash

… when prompted with “Do you wish to re-enable the on-board audio?” say yes.


#3

Cool, thanks. I ran that curl and got an avalanche of code, but was never prompted to re-enable.

Now, I’m getting “Unknown PCM cards.pcm.modem” errors, “The dmx plugin supports only playback,” and “Unable to open slave.”

Thoughts?


#4

it sounds like you are using a jack server?

… sorry about the command above, I was obviously too tired to get it right… you need to pass it onto bash, like so:

curl https://get.pimoroni.com/audio | bash

#5

Just to say that I’ve now added a note to the product description to clarify that you can’t use a heat sink while using Speaker pHAT. Having said that, a heat sink isn’t really necessary at all with a Pi. It will give you a slight performance boost in exceptional circumstances, like extreme floating point calculations on all four cores at once, but for most uses it won’t give you any noticeable performance advantage.


#6

Good to know, thanks! Using the bash, I was able to revert back fine, so I removed the heat sink and the Phat fits a treat. Then I reran the original script to get the phat working and I get the ALSA errors again:

ALSA lib pcm.c:2239: (snd_pcm_open_noupdate) Unknown PCM cards.pcm.modem
ALSA lib pcm.c:2239: (snd_pcm_open_noupdate) Unknown PCM cards.pcm.phoneline
ALSA lib pcm.c:2239: (snd_pcm_open_noupdate) Unknown PCM cards.pcm.phoneline
ALSA lib pcm_dmix.c:961:(snd_pcm_dmix_open) The dmix plugin supports only playback stream
ALSA lib pcm_dmix.c:1022:(snd_pcm_dmix_open) unable to open slave
ALSA lib pcm_dmix.c:961:(snd_pcm_dmix_open) The dmix plugin supports only playback stream
ALSA lib pcm_dmix.c:1022:(snd_pcm_dmix_open) unable to open slave
ALSA lib pcm_dmix.c:1022:(snd_pcm_dmix_open) unable to open slave

Thanks (again) in advance.


#7

I’m guessing that you’re using a different OS than Raspbian?


#8

what command are you running… there is about a gazillion of options out there, some using additional audio frameworks on top of ALSA, sometimes even their own user context, and without configuration specific for your use case it is not surprising you could hit some issues.


#9

Sorry for the delay, lads. Yeah, I’m building a Picroft device.


#10

Picroft is built around a Raspbian Jessie Lite installation, if that helps: (“The lite version of Raspbian Jessie is just like the normal Raspbian Jessie operating system but without any of the graphical desktop environment packages.”) What’s in it is listed here: https://www.raspberrypi.org/forums/viewtopic.php?f=63&t=127060

What packages am I missing for the SpeakerpHAT to work? Thanks!


#11

the speakerphat script installs everything needed for operation, so if you din’t receive a warning that some packages couldn’t be installed (from your distribution sources) then the software side is covered in term of requirements.

My question remains unanswered though, if you don’t tell us what command you ran to get that output we can only guess as to what the problem might be, and have no way to try to reproduce to attempt to formulate a possible way forward suitable for your use-case.


#12

I didn’t run a command. Picroft just boots to a “Waiting for wake-word…” state.
The only errors I can see in the log above the ALSA text says: “amixer: Cannot find the given element from control default.” There is also an “Unable to open 12C device: Permission denied” error at the bottom.

Here’s a grab of my screen:


#13

Hey, guys. I scrapped the PiCroft approach, wiped the disc, and installed full Rasperian on it. Then I ran your one-line installer but still can’t hear any youtube videos. Worried that it might be a hardware issue. Check out the attached photos to see that I installed it correctly. Thoughts?
https://www.dropbox.com/s/4ws0ozi29oa9wo0/IMG_9351.JPG?dl=0
https://www.dropbox.com/s/80yuyj7beiwe0lq/IMG_9347.JPG?dl=0


#14

See my previous post, thanks. I’d love to get this thing working…