Switch back to analog audio from i2s?


#1

I hooked up an i2s amplifier breakout board for testing. This one, https://shop.pimoroni.com/products/adafruit-i2s-3w-class-d-amplifier-breakout-max98357a
Everything worked fine. Now I want to switch back to analog audio as my audio default but can’t figure out how to do that? Right clicking the speaker icon just gets me options for hifi berry dac and USB device settings options?
Preferences > Audio Device Settings only lists the hifiberry DAC (alsa mixer) default. It’s the only listing in the drop down for sound card.
Raspberry Pi Configuration doesn’t list anything for audio.
I tried running sudo raspi-config and forcing analog audio but it errored?
Yes, I am a Linux noob.


#2

Most i2s instructions say comment out “#dtparam=audio=on” in /boot/config.txt, so this may well be your problem. They do this to prevent audio output defaulting to HDMI/Analog, but I think it’s possible to switch between i2s/HDMI/analog with it enabled. I haven’t tried recently.


#3

Sorted, I think? I’ve got sound back out of my speakers. I went to the detailed instructions and basically did the reverse. I unremarked what they said to remark out, and deleted what they said to add.

config.txt was one of the edits I did. I think it was 3 files I ended up editing.


#4

Right clicking the speaker icon now gets me the Analog and HDMI options. Speaker test got me audio so I think I’m good to go. I hardly ever play sound on this Pi but I went to all the trouble of wiring up an analog amp and a set of speakers so I figured I may as well get them working again. This is my bread board setup that I do most of my testing of breakout boards etc on.
The above amp is going to be added to my Google AIY board to give me stereo audio out. The headers are there for it. And I found a forum post (not this forum) that this exact board works with no issues. I still wanted to test it all by itself first though.