Touchphat vs raspistill on Pi Zero W

I have a touchphat on a pi zero w, works great by itself. I had a camera compatible with the Pi Zero w connected, and raspistill worked fine until I put the hat on, now it can’t find the camera. I’ve visited raspi-config and tried all the combinations of GL and enabling legacy camera, etc … but no luck.

So I’m thinking there maybe an issue where they’re both trying to use I2C1. As the Touchphat is physically expecting the I2C1 pins, I think my solution is to change the raspistill to I2C0, though at the moment I don’t know how to do that

Before I try posting this to whatever forum rasipstill uses, I though I’d pose the question here to see if I’m chasing a red herring.

Also since I’m here, I had once run into a site where you could choose different hats to see if there are any GPIO pin conflicts. I wish I had bookmarked that. Does that ring a bell with anyone.

Thanks :)

The pinout is here,
Touch pHAT at Raspberry Pi GPIO Pinout
But the site I think your referring to is here, but I’m getting a 404 error.

The CSI port I believe uses SPI, not i2c, assuming your using an official Pi camera.
If your not please post a link.

You can have multiple devices on i2c, as long as no two devices use the same address.

Thanks for quick response. In the end I think I just fudged up my raspian install somehow. I reinstalled the OS and now everything is fine. Probably should have tried that earlier. :)

I’ve had to do that from time to time. Especially on Pi’s I test stuff on. It’s a bit of a PITA, but its a nice relief when you whats it finally works.
Sometimes doing update upgarde will botch things for you.

Anyway, now you can have some fun.