Trinket 3.3V not working


#1

Hi,

I’ve tried connecting my trinket to my macbook pro, but wasn’t able to upload code (Blink example) with the arduino IDE. I found out that the trinket doesn’t really like USB 3.0 ports so I tried it on a windows machine with a USB 2.0 port, but even here it seems to be not working. I also tried to repair the bootloader which seems to work correctly, but the red light just goes flashing for a second during the repairing of the bootloader and afterwards it only turns on at half brightness for like 2 seconds every time i push the reset button. What could I be doing wrong or is my newly bought trinket broken?


#2

Disconnect GPIO 2 I think it is, if it’s connected, it will never go into boot loader mode while that is connected, took me forever to figure that one out on mine.

I also pulled hair out for a half a day while using a spare USB cable I had in the garage, turns out it came with a light and apparently did not have data cables inside the USB cable!

Edit - It’s #3 and #4, not 2, sorry!

“USB Pins
The next 2 pins are also used for USB programming. That means that when the Trinket is connected to a computer and in bootloader mode or in the middle of uploading a new program, they are used for sending data to/from the computer! It’s possible to share these pins if you are careful. The best use of these pins is as outputs to things like LEDs. We didn’t want to keep these pins off the board but we strongly recommend not using them unless you’re sure you need them since you might have to disconnect any connections to reprogram the Trinket!
GPIO #3 - this is connected to PB3 on the Attiny85. This pin is used for USB programming, but its also an analog input known as Analog A3
This pin has a 1.5K pullup to 3.3V built into the Trinket, for USB comm so it may be difficult to use for analog or digital input.
GPIO #4 - this is connected to PB4 on the Attiny85. this pin is used for USB programming, but it can also be used as a PWM analog output and an analog input known as Analog A2”


#3

Actually I don’t have any cables connected to the pins just the usb cable which is connected to my pc. When I was trying to repair the bootloader I’ve used the wiring diagram of adafruit.


#4

What does the IDE states when uploading? Granted a lot of the time you may get generic ‘timeout’ type of messages it may hold important information you may want to post here.


#5

This is what I get when trying to upload. The trinket is just not found by the

IDE


#6

sorry for the delay, I wanted to try this for myself before I replied. The Trinket does not have a USB to serial converter, so you won’t see a serial port popping up in the IDE, that’s totally normal.

As you have found out though, it’s incredibly difficult to switch it into bootloader mode using a recent Mac. In my case it worked without a hitch from an older MacBook (a mid-2012 model to be exact) but not a more recent MacBook Air. It’s not just a matter of USB 3 vs 2, both of those boosts USB 3 ports.

Out of desperation I must admit I decided to try the USB/Ethernet hub (USB powered) that we sell in the shop since that’s all I had at hand, and it worked first time (and thereafter) from the MacBook Air.

… not sure that helps much, but in case you want to try that this is the product in question:

but the lowdown is that hooking up the Trinket via a (non-USB powered preferably) Hub is your best bet to get it going.


Unable to set bootloader on Gemma on my Macbook Pro