TX RX Explorer Hat Pro


#1

Folks,

Recently purchased an Explorer Hat Pro and am probably try to run before I walk but something I thought would work does not.

I have a USB to UART adapter and configure many of my SD cards this way. I naively thought that, using jumper leads, I could connect the RX and TX on the Explorer Hat Pro board to the corresponding connectors on the adapter cable would work - it doesn’t.

From an Ubuntu machine I used sudo screen /dev/ttyUSB0 115200 - all I get is unformatted screen output which doesn’t seem to make sense, I think it halts at a login section but keyboard entries are unreadable.

Obviously I am doing something wrong, haven’t tried a direct ssh as due to present location only one ethernet connection and Ubuntu’s Realtek WiFi on my machine is very unreliable.

Geffers


#2

Make sure you also have a Ground wire connected, and if all else fails try swapping RX/TX - although I’m pretty sure we swapped the labelling to the right way around some years ago!

I think UART can also be somewhat unreliable on newer WiFi-enabled Pi’s due to the fact the UART hardware is used to talk to the Bluetooth hardware.

You may need to add dtoverlay=pi3-miniuart-bt to your /boot/config.txt and make sure Serial is enabled in raspi-config.

This is documented somewhat technically here: https://www.raspberrypi.org/documentation/configuration/uart.md


#3

Thanks for prompt reply.

It is not installed on a WiFi enabled Pi. I think it is a Pi 2 but can’t see at the moment as HAT covers details. I didn’t have ‘ground’ connected but as mentioned I was getting screen output, just not understandable and KB showing entry but not usual KB characters.

I do have enable_uart=1 in config file.

Geffers


#4

Sorry- I failed at reading comprehension a bit there. It sounds like the two devices are having a disagreement about baud rate, but from what I can tell the Pi does default to 115200. Have you tried mashing the enter key a few times to see if you can get a proper login prompt to pop up? I don’t recall exactly why, but this sometimes works for me over serial.


#5

Gadgetoid, thank you for reply, all working well now.

The only thing I did different was connecting ground - and I used a different computer, an old Acer Aspire One running the Raspberry Pi Desktop. Used sudo screen /dev/ttyUSB0 115200 and it all displayed perfectly this time.

Didn’t think or realise ground would be required but now it is working.

I will obviously use ssh at some later stage but this is useful on occasions.

Many thanks,

Geffers