Testing Explorer Hat Pro GPIO


#1

Hi - what is the best way to check that all the posts on the EHP work correctly?

Specifically, my EHP seems to work in term of the dedicated hardware but I can’t seem to make a serial console connection using TX and RX on the HAT. My Pi powers on but that’s it.

If I remove the HAT I can make the connection just fine so something does not seem right here.

RM


#2

Try connecting TX to TX and RX to RX in exactly the way you wouldn’t normally on a serial connection- I think the labels have been reserved. ( Or put the right way 'round for the connections, depending on how you look at it. )

The PCBs themselves are continuity tested during manufacture, so the chances of the traces themselves being broken or non-functional are pretty close to zero.


#3

yes, I think I tried that, but that was before I got the serial connection 100% working on my Mac (kext signing related problem!). I am going to try from 1 pi to another this weekend and will definitely check your suggestion - sorts of makes sense…


#4

btw, expect some contribution to Pinout2 as soon as I find time, that is an awesome idea and it should be more visible around here, if there is no conflict of interest (but why would there be?)!


#5

I checked the schematic/board layout and the labels are definitely reversed.

I’ve been asked about an embeddable version of Pinout, and I’m giving it some serious thought. I’d like to be able to generate pinout graphics automatically for every board that’s added.

Probably worth another thread for discussion!


#6

nope, I’m agraid that it’s not getting anywhere for me. I tried from my Pi2 (minus 5V, Pi1 A+ USB powered) and same results: works a treat direct from GPIO but not the HAT.

Granted that I had to find a way to accomodate the female header on the HAT (odd choice incidentally) I’m fairly sure the connections are good, if nothing else because the Pi powers up (when hooked up to Mac).

Perhaps you should give me a round up of what I’m supposed to do to use my Adafruit TTL with the Explorer but it’s not like there are a million possibilities.

Anyhow, it’s kind of a big deal for me as I picked up the pro version primarily for this. Ideally I’d like to just hook it up to jy mac while on the road and not depend on a wifi being available.


#7

I haven’t got the right bits with my to test for myself at the moment, but I’ll try it out on Monday if I don’t get swept up by something else.

Are you connecting the Ground wire to one of the Ground connections on Explorer HAT, too?

Generally you would connect Ground to Ground, RX ( in this case ) to RX and TX to TX ( where normally you’d swap RX/TX ) and, if you’ve got a cable that delivers power, 5V to one of the 5V connections ( which is just as good as a power input ).

I’m guessing the wires on the serial cable are female too? How are you adapting those onto the female header of the Explorer HAT Pro?


#8

yes, I ground it, and when hooking it up to the Mac to a 5V post (when using the Pi2 as master it seems that I can’t get enough juice to power ip the A+).

In term of going from the female end of the cable to male, so I can poke in the Explorer’s end (read nothing more into this sentence than there is!), I have tried 2 methods with the same results:

  1. male to male jumper wires
  2. spare pins showed up the TTL end

… because that is a legitimate concern I also tried, with option 2 in place, to use a female to female to go from that frankenstein back to the original GPIO (no HAT involved obviously), and that worked… so I figured that if adding jumper wires and add one point of potential issue works then option 2 should be OK?


#9

It should absolutely be okay- I think I need to do some tests and make sure we haven’t borked something up! Although it’s not impossible that you have a duff Explorer HAT Pro.

We don’t run any continuity testing on those breakout pins ourselves because they’re so incredibly unlikely to fail that it wouldn’t be worth the time, but there could very well be a flaw in the design.


#10

np, Phil. Thanks in advance for your time checking into it, whenever practical for you.

Using a TTL is not going to be my day-to-day use so I can live with this, if it’s not a dead breakout situation restricted to my unit - worst case scenario I’ll get a black hat to access the GPIO in situation I really need access to it and the HAT at the same time… kind of puts a dent on portability but life is too short to worry ;-)

On a sidenote, I wouldn’t feel I needed the serial at all if Adafruit got their Occi software ballpark there (so I could jump on a different network with a headless Pi easily) but my experience a week ago with it was absolutely abysmal.

… they took a perfectly configured Pi, failed to get the functionality their software is supposed to provide, screwed up SMB in the process, and shoved their clunky bootloader down my throat with the rest of the broken party (it rolls in when you call apt-get upgrade). Quite frankly I will be extremely wary of anything they make from here on, once bitten twice shy as they say.


#11

Just stuffed a random serial cable onto a janky old prototype Explorer HAT and it worked first time! It’s definitely not a problem with the design/routing itself, which is good!

I’ll try and dig up my final one with female headers and try a similar setup to yours, but I think you might have a dry solder joint ruining your day. Do you have an iron/soldering experience? It might help just to gently retouch those joints and see if it fixes your problem.

If all else fails, we’ll get it replaced!

Edit: Yup, this abomination works perfectly fine for me too!


#12

cheers for checking… well I can’t say I have a great experience with a soldering iron. On the one hand I don’t think there are any components near the thing that I could heat damage? on the other the points are quite close so it depends if I trust myself not to do a mess and shortcircuit nearby pins ;-)

I guess, if I’m going to get a hot thing near the header I’ll probably go full on and replace it with a male header, I really don’t like that it’s the opposite of the GPIO.

… I’m not at homeright now, but let me have a look at it and see if I trust myself. If not, and I decide to return it, would I be able to pay a little extra to get mine converted to male headers like yours?


#13

Would be a helluva challenge to replace it with a male header- lots of de-soldering, although not impossible if you have a pump.

Try just remelting it first and see if it works :D

You can quite easily adapt those female headers to male using a strip of extended header- I’ll grab some ( if I can still find the stuff after our frenzied office re-arrange ) and show you what I mean. It’d save the pain of soldering, although it would stick out a bit.

I’ll see what I can do regarding male headers if you need a replacement. I have to catch them at just the right moment during production.


#14

I had a look and the RX joint looked like it was on a lead diet so I decided to feed it some solder… and what da ya know, serial connection worked first time so problem resolved :D

btw, does your serial cable really use a reddish cable for the transmit… daring choice on the manufacturer’s part if so.

For any onlooker, definitely do not connect the ‘red’ cable anywhere but the 5V point if your serial cable has a power line (if not using the micro-USB power, if using it then the red cable shouldn’t be hooked up at all since you’re drawing power from the USB).


#15

Yes, it uses a reddish cable! But it lacks a power supply- it’s just Ground, RX and TX. I have a more conventional one somewhere but it seems to have gone missing!

Really glad you got it up and running!