Unicorn pHat does not work anymore after sudo update && upgrade


#1

Hi, I recently update my Raspberry Pi 3 with sudo apt-get update && sudo apt-get upgrade. Since then my Unicorn pHat does not work anymore. Even the Pimoroni examples are not working. I tried to uninstall and reinstall the Unicorn pHat and to reboot, but without any effect to my issue.


#2

Curious! Could you run:

curl https://get.pimoroni.com/diagnostic | bash

And post the output?

Do you get any errors when you run Unicorn pHAT?


#3

output:

  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 12996  100 12996    0     0  57271      0 --:--:-- --:--:-- --:--:-- 57251

Raspbian GNU/Linux 8 (jessie)
Linux kernel 4.4.32-v7+ on armv7l
Revision match: Pi 3 Model B Rev 1.2
Devices on Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.

Unfourtanetly, I do not get any error, when I try to run unicorn scripts.


#4

Thanks! Left my Pi updating so I can see if it’s replicable. I’ll be back after…

BILGE TANK!


#5

D’oh. Not able to replicate. Also on a Pi 3. Also 4.4.32.

The one difference I can see is that my audio is forced to “snd_rpi_hifiberry_dac”, so it could be yet another exciting new audio conflict problem.

What’s in your /boot/config.txt?


#6

This is my config.txt:

# For more options and information see
# http://www.raspberrypi.org/documentation/configuration/config-txt.md
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on

# NOOBS Auto-generated Settings:
hdmi_force_hotplug=1


#7

Ok, I figured it out. Defective contact on a GPIO header caused the malfunction. I replaced it and know it works. Sorry for the inconvenience.


#8

It’s okay! We’ve all been there. Just glad it’s not something to do with the new kernel :D