USB ports Raspberry Pi 3


#1

Built Picade screen does not light,double checked all wiring, put 5v to screen it lights up, no voltage from Raspberry USB ports, I am using Raspberry voltage supply, Help please is this a Raspberry fault or am I missing somthing ???


#2

Do you get 5V from the USB with nothing plugged into them, all 4 ports empty? Do you get 5V on the GPIO pin? Pin 2 and 4 are 5%V and pin 6 is ground.
How much current does that display need to run? The Pi 3B has a Maximum total USB peripheral current draw of 1.2A. https://www.raspberrypi.org/help/faqs/#topPower


#3

Get 5v from GPIO but no volts from ubs cable purged into raspberry with no other leads plugged in except adaptor lead, display was supplied by pimoroni for the picador arcade game, tried all of the ubs sockets on the raspberry but none show any voltage,


#4

Hm, if you had tripped the poly fuse I don’t think you would get 5V on the GPIO? It’s also supposed to auto recover if you let it sit long enough. It goes back to a low resistance once it cools down. Did the USB ports ever work? Like with a keyboard mouse? It sounds like you got a defective Pi?


#5

As far as I can work out the usb have never worked, only time the raspberry was connected was after the build was completed and just plugged the cables in as per the construction video and the screen did not light up,


#6

Must be a fault on the Pi 3? I’d return it or get a replacement if possible. If you bought it from Pimoroni and have had it less than 30 days ( I think its 30 days?) click the About Us link at top of page. Then click the contact us at the bottom of the page that opens. Put a link to this thread in the e-mail and see what they say.