No display following Picade build


#1

Following the build of the Picade unit, and subsequent connect to a 3B+ Pi (with official 2.5A power supply) i am flumaxed.

I see a red light on the pi board beside where the power comes in, but there is nothing displayed on the screen. I have checked and rechecked the connections, including the troublesome ribbon connection to no avail. and indeed the correction in the video to make sure the power connection is in the correct place. I have searched some posts on this forum and tried the config setting thing, but again no avail.

I have a 16gb SD card on the PI which was cloned from a 3, running RetroPie. That is working fine on that unit and setup. indeed my SDcard also works on that unit.

So it is to you i’m coming for help as i’m stuck. I purchase the Picade unit, the PI and the power supply all from you at Pimoroni but i’m stuck and would appreciate some help please?

Thanks in advance

Neil.


#2

I since powered the display directly from a separate mains powered usb. This powered the screen (yay my wiring is good) but then I got like a rainbow square (boo still not working)

Any ideas? I might try the same for the controller card and see if that works. But 3 mains power to fuel 1 device? Really?


#3

The Pi 3 version of RetroPie will not run on a Pi 3B+. You will need to insert it into the Pi 3 and run:

sudo apt update && sudo apt upgrade

Which may get it up and running. Otherwise you’ll need to grab the latest appropriate image from RetroPie and build from there.

Don’t under any circumstances use rpi_update


#4

Rainbow screen as far as I know means a boot issue, as in it’s not booting up. If your card was cloned from a regular 3B (not a 3B+) it likely needs to be updated with new boot code for the 3B+. New firmware/ boot code is needed each time a new Pi Model is released. I see that @gadgetoid has just posted how to do the update as I’m typing my replay. I guess I just type too slow, lol.


#5

Thanks both. I’ll try that. But the other thing is that I only get the rainbow screen when I power the display directly. Is that still a boot issue or a power supply issue?


#6

There are likely two issues going on. The boot issue, and the screen not working issue. You likely were getting the rainbow screen in both instances, it just wasn’t visible when the screen wasn’t working.

Just to recap, everything works just fine with a Pi 3B but doesn’t with the 3B+?


#7

What I would do, temporarily, is power the screen separately and get it booting Ok. Once you get it booting and working OK, then try getting the screen working from the one power supply. The 3B+ will draw more current than a 3B. I assume so anyway, no official current draw figures have been released yet. Just took a quick look on the Pi website and only see the 3B listed. https://www.raspberrypi.org/help/faqs/#topPower


#8

Latest update. i cut a brand new SD card from the RetroPie site (I have tried both Raspberry 0/1 and 2/3) and imaged this onto the SD card.

I have inserted this into the PI and still nothing. the only thing i have noticed differently is that the the PWR indicator on the PI is in a cycle of 4 slow flashes, 4 rapid flashed then solid red then repeats.

Still nothing on the screen, if i do once again give it external power it fires, but i still get the rainbow logo and what i now see is a lightning bolt sign, suggesting something again with power.

Is it something wrong with the PI?


#9

I would try the official latest Raspbian image on the 3B+, https://www.raspberrypi.org/downloads/raspbian/
That should tell you if its a hardware or software issue.
I do believe Retropie runs on Jessie not Stretch. Jessie won’t boot up on a 3B+. You’ll have to use one of the Beta images.
https://retropie.org.uk/forum/topic/16307/retropie-4-3-15-stretch-images-for-testing


#10

Thanks i may try that i’ve tried to Retropie attempts, and NOOB, interesting enough none of these are working on just the hdmi output to a television, again making me think the PI might be goosed.

Thanks for your help everyone much appreciated


#11

The latest Raspbian, will for sure boot from a 3B+, so if that also fails you’ll know for sure its something wrong with the hardware. Either the Pi or the Power supply, or the SD card. If that boots up Ok, then you’ll be pretty certain its not an issue with the Pi 3B+


#12

In Picade you need “hdmi_force_hotplug=1” so that the Pi uses the USB powered display on boot- since the display starts up slightly after the Pi its effectively being hotplugged.

Sounds like you’ve got an underlying issue with your Pi not booting though- it could be the SD card perhaps.


#13

I had this exact problem with my recent build of the new version Picade and solved it with the ‘hdmi_force_hotplug=1’ setting.


#14

I used the Rpi 3B and micro SD card that I had been using as RetroPie system with full HD HDMI display and USB PS3 gamepad. BTW, it’s on Stretch.

I also got the “no-signal” on screen at my first boot.
Then I logged in the Rpi via ssh and installed Picade HAT software, and googled and reached this forum, added following lines to the config.txt.

hdmi_force_hotplug=1
hdmi_group=2
hdmi_mode=16

Got my RetroPie up and running with these lines.
16 is for 60 Hz and 17 (70Hz) and 18 (75 Hz) were OK, too.

One thing I have to do now is to find a better ES theme for the 1024x768 display than Carbon theme which looked great on full HD.