Picade 10" - RetroPie Not Booting

I’ve recently purchased a 10" Picade unit. I finished building it yesterday and overall happy with it, however I have a couple of issues.

Problem 1: RetroPie Booting Issue

I have a Raspberry Pi3 B+ which I’ve been using with RetroPie 4.5. Everything works fine with the official power supply and connected via HDMI to my TV. I then built the Picade unit and put the same Raspberry Pi3 B+ in the cabinet. As the 10" version comes with the HAT board, I’d connected this to the Pie 3. The power supply I’m using is an official power supply that comes with the newer Pi 4 and which I’ve connected using the USB-C cable.

When powering on the cabinet, I can see that the Pi3 goes seems to start up OK as you get the red light, followed by flicking green. However, with the same SD card that contained my RetroPie 4.5 installation, on boot the screen just showed HDMI and then shortly after displayed NO SIGNAL DETECTED. At first, I thought this must be a cable/connection issue, but everything looked good.

So, I decided to get another SD card and flash another Retropie install (same 4.5 version) in case something was corrupted. That flashed successfully and I tried booting that, but had the same problem.

So, I decided to use SD card that came with NOOBS and tried booting from that. That worked straight away and I was able to install LAKKA. So, there can’t be anything wrong with the screen/connections etc. as everything works. I’m thinking that it must be something to do with the flashing of the image?

Problem 2: Power Button

The power LED light on the right-hand side of the cabinet is always lit (very dim). If I press the button, it powers on the Rasp OK. However, nothing happens if you press the button again. Is this be design and you have to pull the power cable every time? I can’t imagine it would be - hence the question. It also seems odd that the LED light is always on. Shouldn’t that just come on when you press to turn it on?

Hi Intex

Problem 1: Boot issue

The first thing I’d try is to connect your TV to the Pi while it’s in the cabinet. If it boots OK like that, it could be that the Pi has somehow become ‘set’ to the resolution of your TV, and now it’s using that with the Picade screen, which can’t handle it. You can force the Pi to a specific resolution and refresh rate in boot/config.txt, details here:


If it’s not the above, then as you say it must be something to do with the RetroPie image.

Problem 2: Power button

I have the original X HAT, so it may work differently to your new version, but this is what I get. When I press to turn on, the button lights up dimly for a few seconds, then goes to full brightness. When I press to turn off, the shutdown script runs, the Pi switches off, and the light goes off.

Are you sure you’ve wired the button correctly?
Also, have you installed the Picade X HAT software?

Thanks for the response.

Problem 1: Solved by adding in a command in the config file to force Retropie to use HDMI.

Problem 2: Solved after I solved Problem 1 above. As I could then see the screen, I was then able to install the HAT software.

Everything now works as expected.