Pi4 Picade issues

I have finished construction a new 10" Picade with a Pi 4 however I’m not sure how to even test if it’s working since Retropie isn’t available for the Pi 4 yet. I have putting NOOBs on a micro SD card however I don’t think the pi boots, the screen doesn’t come on but the red light on the pi is on and the green light repeats a pattern of blinking 4 times. Is it possible to power on the screen if the pi hasn’t booted?

Edit: I changed the title of this post to better reflect the discussion taking place.

1 Like

Hey there,

I may be wrong, but I think the blinking pattern means something’s wrong with your SD card image. How did you prepare the card?

One issue I had a while ago was that SD cards bigger than 32GB are formatted by default as exFAT (and the SD Association formatter will follow this), which the Pi can’t read to boot from (or at least pre-4 couldn’t, don’t know if this has been/will be added now the bootloader can be updated).

It might be a good idea to use Etcher to put a Raspbian image on rather than using NOOBS and append hdmi_force_hotplug=1 to the end of config.txt to test. If this doesn’t work, reprogram the EEPROM as per https://www.raspberrypi.org/downloads/ and try again.

2 Likes

Ah thanks, I will try a Raspbian image. Hopefully I’ll have more luck with it ^^;

Edit: Worked perfectly, thanks for your advice ^_^

I had the exact same thought - how to test the Picade with the Pi 4, now that Retropie isn’t ready yet.
I’m new to both this forum, and to Picade (it’s still in it’s box waiting for the vacation to start)

After some searching in the forum I found this thread. Glad I’m not alone.
I have a Nespi Case+ with a pi3b and I believe it’s Retropie 4.4 installed. It has been a long time since I messed with it, so this will be almost like starting over from scratch

It was kind of a bummer realising that Reptropie isn’t compatible with pi 4 - AFTER I bought my Picade. Well It will come eventually, but for now the Picade is just a box and not an awesome arcade machine.

What are your plans? Waiting for the Retropie guys to come up with a solution? Are there any other alternatives we can use in the meantime?

I was planning to just run Retroarch on Raspbian, however the version in the package manager is missing the core updater and I couldn’t find a package with the cores so I’m going to try compiling it myself. I’ll let you know how that goes ^^;

Edit: In the end I used this guide on reddit to install Retropie on the Pi4

A couple of things you might run into;
This script;

curl -sS https://get.pimoroni.com/picadehat | bash

Didn’t work for me a few days ago, the package manager threw an error trying to install raspi-gpio. It’s better to follow these instructions from github:

Automatic Installation

  • Clone this GitHub repository somewhere onto your Pi: git clone https://github.com/pimoroni/picade-hat
  • Enter the new directory: cd picade-hat
  • Run the installer: sudo ./install.sh
  • Reboot sudo reboot
  • Bind your controls and enjoy!

Similar deal with the plasma buttons it’s easier to just download the source from github, extract it into a directory then enter that directory and sudo ./install.sh

I’m not sure but I think the 10 inch screen draws more power than the USB port can provide. I’ve tried both the 2.0 and 3.0 ports, in both cases if the screen is at 100% brightness it will flick on and off whenever a large portion of the screen is white. If I reduce the screen’s brightness to 75% this no longer occurs. It’s not too big a deal but whenever you reboot the screen reverts to it’s default of 100% brightness. Changing it every reboot gets kind of tiresome.

Lastly I cannot find any way to adjust the volume of the speaker, it works but doesn’t show up as an ALSA device.

1 Like