Using a dual shock 3 controller, can't EXIT Mame in Retropie?


#1

Hello,

I wonder if somebody can help me, I’ve managed to get a PS controller working via Bluetooth in Retropie. I can play all games no problem, button mappings also work for Emulationstation.

I can Exit all Emulators, Nintendo, Megadrive etc using the standard hotkeys, Select + Start but can’t EXIT Mame whatsoever. The hotkeys don’t work.

I know I’ll probably need to edit one of the RetroArch config files but I’m not sure which one.

Can anybody help me please?

Thanks

Scott


#2

Are you on the latest version of retropie? There were significant differences in the dualshock 3 software between 3.8.1 and subsequent 4.x versions.


#3

Yes, 3.81…

Is there an easy way to upgrade? I’m still very new to all things pi?

Cheers

Scott


#4

Have a look here [https://github.com/RetroPie/RetroPie-Setup/wiki/Updating-RetroPie] (https://github.com/RetroPie/RetroPie-Setup/wiki/Updating-RetroPie)- there are a couple of ways to do it but if you’re new to it, it’s good to muddle through. Just make sure you’ve got a backup of your ROMs somewhere…


#5

Hi, I’ve updated to 4.1 but it’s still the same. All working perfectly except whenever I enter MAME I can’t EXIT whatsoever.


#6

Hello, I got it working, I was using Mame4all and I realised it’s not supported by RetroArch, swapped my ROMs over and hey presto it’s working!

Thanks for your help monglet


#7

Hi, I came across below recently, the page is regarding setting up dual PS3 controllers on an older version of RetroPie but the PS button exit mapping should still work (although I haven’t tried it myself yet).

In retroarch.cfg add :-

input_exit_emulator_btn = “16”

more details here