1up button not working


#1

Hi I have just finished building my picade kit, everything seems to be working fine.
Instructions followed to the letter, the problem I have is I cannot get retropie or mame to recognise 1up button, every other button works just fine,
Also horrible hissing from speakers although they work ok

1, swapped buttons
2, checked and redone all connections
1up still not working, please advise

Thanks in advance


#2

Hi Dude

Have a look at this thread to improve the audio quality.
http://forums.pimoroni.com/t/audio-performance-awful/890/13

on the subject of the 1 up button i have a couple of questions:

will it work if you sort the 1up terminal to the gnd terminal ( that the one that looks like a Christmas tree) try using a wire touching the inside of the screw terminal the screws at the top don’t always give a good electrical connection

the other thing to try would be to use different wires on the loom to connect to that terminal just to see of there is any fault connection within the loom.


#3

I’m away right now, will try later today.
I have tried different button and shorted the loom to bypass button, I will try your suggestion when I get back.

Sound issue,

Turned up the volume in retropie gui and has made a massive difference. There is still a slight hiss at full volume but I can live with it.

Thanks for your advice