Volume Up and Down buttons not responding


#1

Hey there, just built my picade, and love it… when it works.

I have a few gripes about the button quality. But first and foremost, my volume up and down controls don’t seem to be working. Maybe the picade board is to blame?

running retropie retropie-v3.8.1-rpi2_rpi3

  • configuring controls, vol up and down do not respond
  • checked and rechecked wiring and connections, everything is secure
  • swapped out buttons with 1,2,3,4,5,6 buttons, still not working (does not light up on the picade board when pressed)

is there anything i can do? I just bought this a week ago from AdaFruit.com, I figure you guys would be better suited for help/repair.

Thanks in advance for your help!


#2

Do you get any sounds at all? When i built my picade I had no sounds. I had to go into the RetroPie menu and then Audio to change the sounds to do Headphones 3.5 mm jack. That worked for me.


#3

I got sounds now - though the right speaker emits a buzz at all volume levels, except lowest - which is hard to hear the games!


#4

Refloating this thread as I have a similar issue.

I built Picade last week but when configuring controls, Vol Up and Down aren’t getting recognised.

However, I’ve noticed that if I hold Vol Up I get a buzz from the speakers and if I hold Vol Down it fades.

Is it not possible to use Vol Down for left shoulder and Vol Up for left trigger?

Thanks!


#6
  1. It’s possible this could be related to other issues we’ve seen with the audio input connector coming loose from the board, Could you possible post a photo of your setup, paying particular care to the audio input?

See the example @rabid_inventor provides in this thread: Dodgy speaker maybe?

  1. You can use the volume buttons to trigger any keyboard key or gamepad button using the newer Picade firmware available here: https://github.com/pimoroni/Picade-Sketch/tree/master/update