Picade Volume Issues


#1

Hi! Just finished building my Picade and have installed my first game…;). Everything was going swimmingly, but the audio is giving me issues. The volume is too low at 100%…I’m using the correct powersupply…any ideas? Also, where can I find what buttons do what on the 5 button screen control board?

Thanks,

Nick


#2

the ‘buttons’ terminal are generic in the sense that they can be customised in the firmware if you want to and you need bind them from within Emulation Station, RetroArch, or by modifying individual emulators configs.

If you’d like to see what they are as shipped in your currently installed firmware you should be able to use showkey ad inspect what keycode they relate to: http://www.comptechdoc.org/os/linux/howlinuxworks/linux_hlkeycodes.html

when you say the volume is at 100%, how do you assess and control volume currently?


#3

Hi RougeM, thanks for the response. I currently assess the volume using the
menu dialog that comes up in Emulation Station.

There was some behaviour change somewhere…the volume was initially fine
but after a software update and installing all the retropie stuff the
volume is seriously lacking…I’m not that linux savvy, but I have the
capability of uploading arduino programs etc…


#4

have you tried using the volume buttons on the Picade itself, they do control the volume going out to the speakers (proportionally to the level entering the board via Audio IN jack).


#5

here are the keys associated with the buttons btw (if you haven’t modified a firmware to accommodate custom keycodes):

button 1 - keycode 29 - L CTRL
button 2 - keycode 56 - L ALT
button 3 - keycode 57 - SPACE
button 4 - keycode 42 - L SHIFT
button 5 - keycode 44 - Z
button 6 - keycode 45 - X

… and I might as well post the keycodes returned on the other terminals:

L - keycode 105 - Left
R - keycode 106 - Right
D - keycode 108 - Down
U - keycode 103 - Up

1UP - keycode 31 - S
1/4 - keycode 46 - C
ESC - keycode 1 - ESC
ENT - keycode 28 - ENTER


#6

Stupid question here…where are the volume buttons on the Picade itself?


#7

next to the LEDs… you need to wire them between input and ground, obviously.


#8

… and if that still does not work, try to exit RetroPie and at the command line run alsamixer to verify the output from the Pi is as high as it can be.


#9

Thanks, I have verified that the Pi is outputting 100% from one of the
system menus…any reason why the volume controls on the Picade weren’t
brought out to the case in some way or have I missed something very basic
here (highly likely! ;-).

Nick


#10

I’m not sure I follow… you should have been provided with 12 buttons and the case can accommodate as many? 2 of those are for volume control.


#11

Ah ha! I knew I’d missed something bloody obvious…I will report back.


#12

Yep, looks like my son pressed the volume buttons without me actually
realizing they’re volume buttons [face palm]…!

Problem solved! Sorry to muck you about!


#13

No problem! Easily done…

I’ll close the topic now…


#14