Updated Picade Firmware, No Sound


#1

Hi There,

I recently purchased your Picade and I think it’s great. I just have a small issue.

I did the firmware update of the Picade because I would like to use the gamepad update that was added.

The update seem to go fine but when I rebooted the Picade, the controls were working fine but found that I no longer had sound from the speakers.(the sound was working fine from the audio jack on the side.)

I would like to know is it possible to revert back to the keyboard only firmware?

Thanks Again.


#2

Hi

Have you tried increasing the volume using the volume buttons on the left hand side of the Picade.

Cheers

Paul


#3

HI,

I have. The Volume keys do nothing now. The volume keys are seen now a button keys now when I go into the retropie buttons configuration screen. Maybe i’m wrong but I think i understand the the new firmware turns the volume button into extra controller keys? I was unaware of this.

Thanks


#4

Hi

You can rebind the volume keys to work as volume keys. If no-one else replies before tomorrow I’ll send you my script to do it. Not near the Picade at the moment.

Cheers

Paul


#5

That would be great thanks.


#6

Hi

Just remembered I posted it on the forum here
http://forums.pimoroni.com/t/new-2-x-configurable-keyboard-gamepad-firmware/1881/32?u=paulcheffus

You will need to copy and paste the code in the link into a file called something like keybind.py and then run it using python keybind.py

Cheers

Paul


#7

Hi Paul,

Thank you for that information. Unfortunately I am quite new to all this so I would have no idea of how to transfer the python code to the Picade.

I might just try and flash the old keyboard only firmware back onto the Picade Board and hope I don’t end up bricking the board!

Thank you for the help, most appreciated.

John


#8

Hi

Create a file using nano keybind.py
Type in the code given
Save it using CTRL + X and enter Y to save
Run using Python keybind.py

Cheers

Paul


#9

Hi

There is another option. I can modify the firmware so that it maps the volume controls by default and send you a copy. All you would need to do then is apply the new firmware.

Cheers

Paul


#10

Hi There,

It’s ok, I got it sorted.:-) I watched your video on the firmware update and and managed to access the picade button config via putty. Set the config back to the keyboard config and back in business. :-)

Least I now know what to do now for future reference. Thanks for your help on this.

John


#11

Out of interest did you use picade.hex or picade_b2.3.hex?

It may be time for me to retire the former and make another release.


#12

I think I updated with the picade.hex firmware.


#13

Ah yes that was the old release. I’ve bumped the beta 2.3 version into picade.hex now, so if you update again you should get the latest bug fixes and tweaks.