(6) Could not resolve host


#1

Hello. I have tried to search for a post that describes my problem but have not been able to find one, so if there is a fix for this already please let me know and sorry for doubleposting.

I am trying to curl -sS https://get.pimoroni.picadehat | bash but all I get is “(6) Could not resolve host”

I have changed to English (US) layout and I have setup wifi. What could I have missed?

Best regards,
Huligran


#2

Work or at home? Sometimes the company firewall will cause errors like that.


#3

At home, do you think it could be my router causing this trouble?

Best regards,
Huligran


#4

Honestly not sure? Try this instead
curl https://get.pimoroni.com/picadehat | bash
Original Picade hat or Picade X-Hat?


#5

I get the same error message. I have the Picade X.


#6

Ok, it looks like the first one you posted is the one to run.
curl -sS https://get.pimoroni.com/picadehat | bash
From here, https://github.com/pimoroni/picade-hat , can you navigate to that page in a browser?
Phil @gadgetoid may know where to go what to do next? There might actually be something amiss on thier end?


#7

Yes I can navigate to that page. Worth mentioning is also that I tried sharing a mobile hotspot and accessed through that as I thought maybe the router was causing this issue but the same error message. I’ll ask gadgetoid if he knows anything, thank you for your help!

Best regards,
Huligran