PiCade Console PiHat setup


#1

Hi,

I’ve just finished building my PiCade Console seem to have an issue setting up the PiHat can you help?

I found this post but https://forums.pimoroni.com/t/envirophat-set-up-problem/3220/3

but when I run the ```
curl -sS https://raw.githubusercontent.com/pimoroni/get/master/installers/envirophat | bash

I get the error bash: line 1: 404:: command not found - any ideas?

Thanks,

Crofmmv

#2

That first link you posted doesn’t work for me, its not clickable. Looks like it set as code instead of URL.


Anyway, why are you running the enviro phat installer on your Picade hat?
curl https://get.pimoroni.com/picadehat | bash is the recommended install code.
From here, https://shop.pimoroni.com/products/picade-x-hat


#3

Hi,
I get an error when I run “curl https://get.pimoroni.com/picadehat | bash” Checking enviroment…

We can’t connect to the internet, check your network!

Crofmmv


#4

Ok, I have to ask the obvious, do you have an Internet connection?
And if yes, where are you running this from Home or maybe at work?
To do what was done in that other thread youd need to run something like this
curl -sS https://raw.githubusercontent.com/pimoroni/get/master/installers/picade-x-hat | bash
Just a guess on my part so don’t be surprised if it also fails.


#5

Yes I have an internet connection using the ethernet port.

I get the same error running that command bash: line 1: 404 command not found.

Crofmmv


#6

That was just a guess on my part. It sounds like your router or a firewall may be blocking access to the web site URL? Thats why I asked if you were trying to do this from a work location?
Or you made a typo and or didn’t clip and past the command in properly?


#7

That’s an old post- the “get” GitHub repository is currently private so you can’t access any of the files there.

The same scripts are hosted on “get.pimoroni.com”, the one for Picade HAT is-

curl -sS  https://get.pimoroni.com/picadehat | bash

#8

The above command worked thank you :)

Crofmmv