64x32 RGB LED MATRIX not working - please help!

I’ve been trying to make my LED board work for the past 10 hours, but no matter what I try nothing happens.

For context I have:

  • Adafruit RGB Matrix Bonnet for Raspberry Pi
  • RGB LED Matrix Panel

I’ve tried disabling the 1-wire and enabling it, as well as followed the advice on this https://learn.adafruit.com/adafruit-rgb … g-matrices and this viewtopic.php?t=183781 but nothing is working. I’ve tried troubleshooting, checking the GPIO, run a whole bunch of commands. There are no noticeable errors, the LED just isn’t lighting up.

Is there something I’m missing?

Please someone advise!!

Thanks :)

I’ve got exactly the same problem! Tried on a Raspi zero 2W & also a v4 in case it was my soldered header.
No luck with either. Please let me know if you find anything!!!

Did you see the other person’s comments that it worked with a 32 bit OS? Might try that myself. Will let you know if I get anywhere.

no i didn’t see that comment! could you link me to it? we think it’s actually a power supply issue and tested with a smaller screen which worked - but i’ll try your recommendation today as well and let you know!

Could well be; the product page quotes “<=20w” for the 64x32 panel, and that’s before you leave any for the Pi itself.

we’re using a 5V 3A power supply, which is 15w. do you think i should go for a 5V 4A power supply?

thanks :)

Well I mean in theory it should be enough unless you had everything bright white anyway, but not all PSUs are equal, I guess?

i think it’s actually an issue with the LED board itself… because everything is working fine on a 32x16 board. i’ll try with a higher voltage but maybe i’ll reorder a board.

Just a FYI post. I have two 64x32 panels setup as 64 x 64, it was the only way to get the pixel spacing I wanted. I’m using a Pimoroni Interstate 75 (RP2040 Micro Python). My current (no pun intended) supply is a 5V 4A switching power supply. Smooth sailing once I got my code working. ;)

Don’t cheap out on your power supply. And buy a power supply, not a “charger”. I’m not saying you did, just some words of wisdom from somebody who has been there done that. ;)

I’m using a 10A 5v supply for a 32 x 64 display. Nothing at all is showing though! Not even one LED :-(
@alphanumeric - what version of Raspberry Pi & what OS are you using please?
It should all just work out of the box and I’ve done tons of Raspberry Pi projects in the past without issue.
Just this one seems to not want to light up!

No Pi, The Interstate 75 is RP2040 based. It’s flashed with Pimoroni’s custom Micro Python uf2 file. Most of my code is Pico Graphics.
Weather info displayed as text messages.