A Very Basic Question about Picade


#1

Hello, Im not at all technicaly minded but am having ‘a go’ at building an arcade machine.

So stuck right at the start, do I have to fit my Rasbery pi B and picade hat together or do I just connect it to the usb on the rasbery pi B via a micro to standard usb wire?


#2

If it’s the Picade Hat that you have then it sits on top of your Pi.


#3

Cheers, Im starting to think my rasberry pi is the wrong modle as the connector on the picade has more holes than I have pins on the rasbery pi

this link is to a picture of my type of pi which is the one on the left it has the caption of Model B’s 26W vs Model B+’s 40W GPIO connectors


#4

So do I need to buy a new pi3 ?


#5

From the description it looks like the micro USB on the Picade Hat is just for power purposes so it does sound like you’ll need to upgrade to a 40 GPIO pin model


#6

The pinout is here, https://pinout.xyz/pinout/picade_hat# Going by that, yes, you need a Pi with a 40 PIN GPIO header.


#7

Great at least I have a plan now, ill get one ordered. Thanks for your help


#8

hello again everypone, so I have my new pi 3 and connected it to the picade hat but it says under voltage, I have plugged an official powersupply that came with my original pi which has the following pronted on it, outpur 5.0 v 1.0 A the power supplies in the shoip have the following 100-240v input, 5.1v 2.5A output

So do I need to buy a new power supply?

Also do I plug it into the Rasbery pi 3 or the hat?

Thanking you all for your help so far!


#9

5V with only 1A out isn’t enough to drive a 3B and a Hat. It would be iffy just driving a Pi 3b all by itself. The recommended power supply for the 3B is 5V with up to 2.5A out. So yes your 5.1V 2.5A shop supply should be fine. Assuming its a power supply and not a charger. The 5.1v isn’t going to hurt anything. Under load, at the Pi your getting 5V, or close to it.


#10

I don’t think it matters which one you plug it into, you’ll get power to both either way. The 5v, 3.3v and ground are linked between the two. In the description of the picade hat it states, “Micro-USB connector for power (back-powers your Pi)”.
Be advised though, that I do believe plugging into the Picade Hat will bypass the poly fuse in the Pi? I’ve done it on a couple of my Pi’s. I feed power in via the GPIO pins. It’s only an issue if you get a short circuit somewhere. It’s not something that bothers me. To play it safe just plug your power supply into the Pi.


#11

Thats great thanks, Ill get my new power supply ordered


#12

It can add up quickly, the current that is. LED’s, any display connected to the GPIO, or a display on HDMI that also needs 5V power from the Pi. Servo’s motors etc. Save the 1A supply for a Pi Zero. ;) I almost always add a Pi Zero to my order. It’s just to inexpensive not to. I think I have seven Zero W’s kicking around here last time I counted. Four of them are actually in use and dedicated to a project.


#13

Hello again everyone, So just had me new power supply delivered, no more voltage issues, however the instructs say I have to type the following in

curl -sS https://get.pimoroni.com/picadehat | bash

but my little keys board gives a different symbol for the didgit before the word bash, would anyone know what the country code in retro is for the uk?


#14

Is it a UK layout keyboard? I have the same issue with my English US keyboard on a stock install. Raspbian defaults to the UK layout and that messes up my keys. Once I switch it to English US the | is where it should be. I have yet to ever get it sorted with Raspbian Lite though. The raspi-config menu is different and no matter what I try I can never find the | symbol on my keyboard. And no way to run the one line installers.


#15

Yes its supposed to be a uk keyboard but it was a cheap one so it may think its from another country. Its a Mini I10 wireless keyboard made in china.

I was thinking of linking my pi to a laptop with an ethernet cable but to do that I have to type in

~$ sudo apt - get install xrdp

and my keyboard doesnt seem to have the wiggly line at the start!

is there perhaps a comand i can type in to change the keyboard country layout so I can quickly go down the list of keyboards to find one that will allow me to type these two symbols?


#16

Press the ~ key, then take note of what symbol actually comes up, then press that key and see if you get the ~. That worked for me in the past, when I got my first Pi and didn’t know I had to change my keyboard layout.
That being said, I don’t think you need the ~. All you need to run is sudo apt-get install xrdp. The ~ is like the C:| prompt in dos. I think anyway?


#17

EDIT: Just booted up my spare desktop running the Desktop version of Raspbian and edited for better instructions.
If your running the lite version of Raspbian you run sudo raspi-config from the terminal.
Then choose Localization menu > change keyboard layout.
If your at the Desktop GUI go to Preferences > Raspberry Pi Configuration > Localization > Set Keyboard.


#18

Hey Hey, so Ive bought a new Microsoft Wired 600 keyboard which has allowed me to install the required software. Is the retopie emulator supposed to see it as a keyboard?

Its just that if I go into the configureation menu in mame and try to set the joystick up it wont allow me to change the inut buttons as soon as I press up for example on the keyboard it stops respnding.

Am I missing a driver or something?

Its a long road for me!


#19

I can’t help you with that, I’ve never used retropi or any arcade type of software on my Pi.


#20

toot toot, i dont know what i did but got it all working!

So anyone know how to have it so when you turn it on it boots straight into a game like a rel arcade machine?

Thanks for all your help so far by the way!