Adafruit Mini PiTFT

Hi, took delivery of the above yesterday but I cannot get it to work.

I started with the latest Raspbian Buster image on a Pi 3A+ and updated/upgraded it.

I then followed the instructions as per - i.e.:

sudo apt-get update
sudo apt-get install python-rpi.gpio python-spidev python-pip python-imaging python-numpy

However, python-imaging failed but advised to install python-pil instead…

then did sudo pip install st7789, however, as I’m using Thonny based on Python 3 I also did sudo pip3 install st7789

I’d forgotten to enable spi and i2c so enabled them and rebooted.

I ran sudo Thonny and tried the various examples from the Github page, however, there’s no output from the display, save for the backlight being lit.

What am I missing…?



Buster with Desktop or Buster Lite?
I ask because the Buster Lite image is missing a bunch of stuff. smbus and pip to name a few.

Hi, Buster Desktop…


I’m not sure if this helps or not but here goes.
I was just playing around with my Fan Shim.
If I install with sudo pip install fanshim, and try to run some code from Idle3, I get a no module names fanshim error.
If I install with sudo pip3 install fanshim, everything works from Idle3 / Python3. I think you already know that though.
I don’t own a mini PiTFT screen so I’m not sure how much more help I can be. Buster seems to have put a wrinkle in things for a lot of people.

Hmmmm, OK, thanks for that, I’ll try an older OS build tonight…

You can get the older builds here. I’d try the latest / last Stretch release. If it works you’ll know its a software issue not a hardware issue.

Still not working under 2019-04-08-raspbian-stretch-full - same result, no errors, backlight on - no other sign of life… :-(

However, just followed and the Quickstart Button Test works - more investigation needed…

You could try posting this issue on the Adafruit forum, they made it after all. I go by the same username I use here, there as well.