Rasp lite

I have a RPi 3B+ and fitted the shimfan, and as expected, works great, but as no software loaded yet, no control. Because I have the Rasp lite loaded, is this an issue with installing shim fan? When I input, via putty, sudo pip3 install psutil --upgrade…not sure if this is how i start the load process…i get the comment back, sudo: pip3: command not found…
I tried this as well…
git clone https://github.com/pimoroni/fanshim-python
cd fanshim-python
sudo ./install.sh
but this was also not understood.
So, could you please advise what is the process for installing the software for the shim fan from the beginning.

@davidm posted this in another thread. It’s just a partial quote.

The lite version of Raspbian Buster hasn’t got python-pip and python-smbus installed.
The below and a restart, got the script running.
sudo apt-get install python-pip
sudo apt install python-smbus

Hi alphnumeric, This is the very first day of my RPi so nothing is obvious to me. So, you are saying, when booted up and at the command prompt, I insert (in my case, via putty)
sudo apt-get install python-pip…do I input this line first, then enter the second line?
sudo apt install python-smbus…then after this has occurred, do I then insert this, all lines combined?
git clone https://github.com/pimoroni/fanshim-python
cd fanshim-python
sudo ./install.sh


I’d run sudo apt-get install python-pip from command line.
Then do a sudo reboot
The see if sudo pip install fanshim will work.

ok, getting closer? My last result. Could not find command “git”
pi@raspberrypi:~ sudo pip install fanshim Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple Requirement already satisfied: fanshim in /usr/local/lib/python2.7/dist-packages (0.0.2) Requirement already satisfied: plasmalights in /usr/local/lib/python2.7/dist-packages (from fanshim) (0.0.1) Requirement already satisfied: RPi.GPIO in /usr/lib/python2.7/dist-packages (from plasmalights->fanshim) (0.7.0) pi@raspberrypi:~ git clone https://github.com/pimoroni/fanshim-python
-bash: git: command not found
pi@raspberrypi:~ cd fanshim-python -bash: cd: fanshim-python: No such file or directory pi@raspberrypi:~ sudo ./install.sh


I have a fan shim installed on my Pi 4B. I haven’t installed the software though. Give me a little while and I’ll run the installer and see what comes up. And have a look at what directories etc are created.
I’m running Raspbian Buster with desktop.

Thanks for the quick reply. I got it sorted. I needed pip3 and I needed sudo apt-get install git…A bit of trial and some error, and now my fan stopped, so I guess it is “working” as per instructions. Amazing little thing…like back to my DOS days in the 70’s

Ah, good stuff, well done. I was wondering if it needed to be pip3 for the Python 3 version? I almost put it down as a try this option, but got sidetracked.
I didn’t bother installing the Fan Shim software on my last fresh Buster install. I just let my fan run continuously while the Pi is on. My temps are right around 40c no matter what the Pi is doing.
I did install the software when I first got it, just to make sure everything worked as advertised. I can’t see the LED with my setup anyway, and the button still works without the Fan Shim software. For what I use it for anyway. doing a shutdown when pressed.

Looking in my case now, I see a bright green LED. When you say 'button", is there a button some where for the fan? Though inside the case, a tad difficult to get at.

My little guy will be on 24/7 providing data to FR24, so wanted the ‘insurance’ that it will attempt to cool down the innards. A Brisbane summer when no a/c can be a tad warm for the RPi.

Running vcgencmd measure_temp or mine now is 53.7c (ambient = 24c)


There is a small button right next to the LED on the board edge. It’s pressed from the side. It’s wired to two GPIO pins. BCM 3 wake and BCM 17 button. When pressed it grounds those two pins, but only while depressed.

With the latest eeprom code on the Pi 4, grounding GPIO 3 will make it boot up if it has power. And with a config.txt edit adding dtoverlay=gpio-shutdown grounding it while the Pi is running does a proper OS shutdown. The latter is what I use it for. The other pin is I believe what the fan shim python examples use to detect if its pressed or not.

Just a FYI post. If you don’t install the Fan Shim software, the fan will just run continuously as long as the Pi is powered up. The software actually turns if off by grounding the fan control pin. With no software installed that pin is floating which is effectively a high (as far as the fan shim is concerned) so the fan runs. Best guess is its a failsafe incase the software doesn’t work.

Yes, I saw where the fan runs as soon as the RPi is powered. Because I now have the Fan Shim installed(with your great help), the fan immediately stopped. I guess it will fire up every startup, then the script will kick in, and shut it down until temps kick in. Agree, it is better if the script failed, causing the fan on, than to fail causing the fan off. fan is super quiet. I see where it is recommended the RPi4 has a fan because of more grunt and therefore more heat generated.

Yeah, as soon as you plug in your power supply the fan will start. Then latter on once Raspbian boots up and starts the fan shim daemon it goes into auto mode. The reverse happens on shut down. If its off when i press the button, a couple of seconds latter when Raspbian shuts down it turns on. Only way to stop it is to unplug my power supply.
I’ve just been using heatsinks up until now. I initially just had the Pimoroni heatsink on my Pi 4. Working hard under load though my temps went up to 80c. So next order I added a fan shim. Now its nice an cool.