Alexa With Phat Beat


#1

Alexa With Phat Beat
Hi, Please help.
I have a Pi Zero W with a Phat Beat. It works perfectly well as a pirate radio but I decided to start a new project and turn it into an Alexa. I wiped the SD card and installed a new version of jessie lite, I then used the script to install the Phat Beat. That all worked fine and I got sound and LED’s when tested.
I then installed Alexa following the instructions here;


It all seemed to work apart from there is no sound output only LED’s. I’ve had a search around the forums and haven’t come across this problem but there was someone with a similar problem when installing spotify.
I am only learning with the Pi so have limited knowledge. Would it be better to install the Alexa first and then the Phat Beat.

Regards
Andy


#2

I’d run the pHat Beat installer again and see what happens, before starting all over again. I have a pHat Beat, absolutely no experience with Alexa though.


#3

Hi, thanks for your reply. I should have tried that but my head was a bit mashed, it was one of those days.
I’ve just rerun the phat beat script but it didn’t work, still the same problem.

Andy


#4

It was worth a try anyway. You had sound out of the pHat Beat before so it’s not a hardware issue. Pi Zero doesn’t have an analog out so its not going there. Vu meter is working. Right click the speaker icon in the tray and see what is set as the default audio out.


#5

I’m on jessie lite so no speaker icon, is there a way to do that through terminal?


#6

That I don’t know? There likely is a way but I’m a Linux / Raspbian noob.


#7

Have a look see at this, https://www.raspberrypi.org/documentation/configuration/audio-config.md might help?
Or, http://blog.scphillips.com/posts/2013/01/sound-configuration-on-raspberry-pi-with-alsa/


#8

Thanks for that info. I’ve worked through it with no luck but I have found something interesting.
If I use alsamixer, sound output is set to PulseAudio and altering the volume does change the level of the LED’s on the PhatBeat. If I press F6 to change the output device, I get the option snd_rpi_hifiberry_dac, which I’m assuming is the correct setting. However, if I change this and exit alsamixer it still does not work but when I go back into alsamixer, it has reverted back to PulseAudio.


#9

Have a look see what is listed in your config.txt
sudo nano /boot/config.txt
Mine has

interfaces
dtparam=i2c_arm=on

dtoverlay=i2s-mmap
dtoverlay=hifiberry-dac

Everything else is remarked out. Any line with a # in front is ignored. That’s on my Pirate Radio install running full Jessie with a pHat Beat.


#10

This may, or may not, lol, help.
https://manpages.debian.org/stretch/pulseaudio/pulseaudio.1.en.html


#11

dtparam=i2c_arm=on
Was remarked out so I changed it but it hasn’t worked.
Thanks for trying I do appreciate it.


#12

That was likely there in my config.txt because I turned i2c on manually. It looks like the pHat Beat doesn’t use it anyway, it only uses SPI, which I think is the i2s entry.

I think you’ll need some input from @gadgetoid or @sandyjmacdonald to sort this out.