pHat Beat - doesn't work


#1

Hi,
I’m using a fresh install (noobs install fresh download of raspbian-lite) and have done an install of the one line installer as per the instructions.
=>Getting Started with pHat Beat.
I’m using a pi zeroW and have tried 2 different SD cards and 2 fresh installs

Currently when I run the speaker test the piZero W resets

When running headless I get the following output
pi@zeroPi:~ $ speaker-test -c2 -t wav

    speaker-test 1.1.3

    Playback device is default
    Stream parameters are 48000Hz, S16_LE, 2 channels
    WAV file(s)
    Using device: phat-beat
    Rate set to 48000Hz (requested 48000Hz)
    Buffer size range from 128 to 131072
    Period size range from 64 to 65536
    Using max buffer size 131072
    Periods = 4

Any help as to where to start trying to work out why this doesn’t work

Thanks

Shane

,


#2

Could easily be a mechanical issue- could you post a photo of your soldering on both the Pi Zero and pHAT BEAT?


#3


Couldn’t see any obvious soldering errors up close


#4


#5

Looks good- I can’t see anything obviously wrong with it. Anything looking untoward on the other side of pHAT BEAT?


#6

Nothing I can see. Speakers well fitted. I’ve tri d it with mono and stereo.

I’ve nothing to go on

Happy to do any tests that people could suggest


#7


#8

The rebooting suggests that it could be a power issue. How are you powering the Zero W?


#9

Good thinking!
I’ve changed over to a 2A 5V official RPi power adaptor.
It gets a tiny bit further in the speaker test (with a crackle from the speakers) and then crashes again
This is the SSH output now

speaker-test 1.1.3

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Using device: phat-beat
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 128 to 131072
Period size range from 64 to 65536
Using max buffer size 131072
Periods = 4
was set period_size = 32768
was set buffer_size = 131072
 0 - Front Left
 1 - Front Right

Any other suggestions will be gratefully received.

Shane


#10

Hi, my experience installing pirate radio after five attempts.

  1. Downloaded latest Stretch Lite sept 7.
  2. configured wpa_supplicant.conf to connect to my wifi network.
  3. sudo apt-get update && sudo apt-get dist-upgrade -y
  4. made localasation for keyboard and country (FI in my case)
  5. Used one-line installation curl https://get.pimoroni.com/vlcradio | bash
  6. Waited some 40 minutes for installation to complete
  7. after reboot preinstalled stations came alive.
  8. edited /etc/vlcd/default.m3u to my favourites
  9. after reboot works to perfection

Summary: It took me three days to get Pirate Radio to work. Lots of reading on the forum inbetween to get more understanding of the phat-beat.

Other comments:

  • Loudspeaker terminals are lousy,
  • Volume + - react rather slowly

Calleblyh Helsinki


#11

I’m acutely aware of the setup woes people have been having with Pirate Radio. I’ve been spending a lot of time making a “ready to go” software install which you just unzip to an SD card and configure with your playlist/WiFi preferences.

I haven’t been able to get Volume to react any quicker, unfortunately, it seems to be a VLC thing, but I’ll look into it.

I’m in two minds about the speaker terminals. With nicely tinned wires that are just the right size, they work a treat and are less of a pain than screw terminals (and also keep the cost down, since they’re surface mount) but with anything even slightly straying from a “nicely tinned wire” they are somewhat frustrating. I’m kinda with you on this one, but unfortunately we haven’t found a better alternative. (Better being a surface mount part with the right balance of functionality and cost).