Pirate Radio Loudspeaker silent


#1

About half a year ago I bought Pirate Radio from Pimoroni. Yesterday I had time to put into operation. I made three installations attempts to get software installed. All exactly according to instructions. Main problem I get no sound out. I am using latest Raspbian Stretch Lite from september. VU-meter is working straight after boot. Like there is some sound, but I cant hear anything. I have tested ./test.sh. Seems to work, buttons responding correctly. There is NO playlist.m3u. so why is VU-meter showing there is a signal ? What more can I test ? How should I test “test.wav” ? Obviously I have missed something. I am desperate, please tell me what to check…
calleblyh Helsinki


#2

There is a default playlist, don’t remember what folder it s in at the moment. I’d have to hook a monitor up to my Pirate radio to find it. By default it should automatically play the first station in the playlist. Mine does on first boot up. After that it remembers what channel you were last on.
Stretch might be the issue. My install is Jessie, I have heard other complaints when people used Stretch.

Switch on pHat Beat set to mono? Have you got another speaker to test with? When I wired up my speakers, I used a small screw driver to depress those quick release things, just enough so my wires slipped in easily. I found that easier than just trying to push them in by force.


#3

Thanks for your reply,

In the meanwhile I found the playlist in /etc/vlcd/default.m3u. And via web it plays the first entry have I confirmed. I have connected two speakers L and R, used the switch in mono and stereo, still no sound on speakers. all buttons work properly. Maybe the problem relates to Stretch Lite. Pimoroni guru, please confirm !


#4

/etc/vlcd/default.m3u << That’s the spot. For what its worth, I use the full Jessie. I just set it to boot to command line instead of the desktop GUI. The last time I started from scratch I just used the one line installer from here, https://learn.pimoroni.com/tutorial/sandyj/internet-radio-on-your-pirate-radio

curl https://get.pimoroni.com/vlcradio | bash

#5

I made a fresh install on raspbian jessie from feb 2017. Still same problem, no sound.
I did some reading on the forum regarding phat-beat and found the speaker test, result:
Jessie: speaker-test 1.0.28 Playback open error: -16,Device or resource busy
Stretch: speaker-test 1.1.13 Playback open error: -16,Device or resource busy
So, what’s blocking the device ?
I also treid the phat-beat module on top of RPi3B and the same problem remains.
is there a tutorial on all test syntaxis I can run for the phat-beat ?

This is a most interesting problem, which needs to be solved


#6

Ok, did some more reading on the forum. In /boot/config.txt last three lines should read:

dtparam=audio=on ( was #dtparam=audio=on )
dtoverlay=i2s-mmap ( was correct )
dtoverlay=hifiberry-dac

My Pirate Radio works now.


#7

Yeah, anything with a # is treated as a remark and basically ignored. I’d have to read up on what “dtparam=audio=on” does to understand what happened. Great that you sorted it out.


#8

Unfortunately my judgement was slighly premature, Sound came via HDMI output to my TV-set used as monitor, so I am still struggling to get a headless internet radio


#9

Ah dtparam=audio=on must have turned the onboard audio back on? Keep in mind, the Zero doesn’t have any analog audio out, like a 3B does. It’s only option without any addons is HDMI. The one line installer for the pHat Beat switches audio to SPI, as far as I know. I’d double check that that enabled in RasperryPi configuration.
There is also a Pimoroni installer you can download and install
sudo apt-get install pimoroni. I install my Explorer pHat that way. Will also work for the pHat Beat. It won’t install the VLC Radio (Pirate Radio) stuff, just the pHat Beat stuff. The audio test should be doable. To be honest it sounds like you may have got a dud pHat Beat. I would use the contact us link to report it.
https://shop.pimoroni.com/pages/contact-us
Link to this thread.


#10

Don’t take this the wrong way but I have to ask the obvious question. Did you strip the insulation off of the ends of the speaker wires so there is bare wire showing? Tinning those ends with solder will make plugging them in easier. And, you didn’t maybe push them in too far into the pHat Beat? Pushed in too far may make the insulation in contact instead of the bare wire.


#11

Hi, and thanks for your contribution

Indeed I did strip the insulation, I have experience in these kind of clip-on connectors from other projects. But anyhow a good point to point out.

This morning I did a successful installation (my 5th attempt).

What I did:
Downloaded a fresh latest Stretch Lite sept 7.
configured wpa_supplicant.conf to connect to my wifi network.
sudo apt-get update && sudo apt-get dist-upgrade -y
made localasation for keyboard and country (FI in my case)
Used one-line installation curl https://get.pimoroni.com/vlcradio | bash
Waited some 40 minutes for installation to complete
after reboot preinstalled stations came alive.
edited /etc/vlcd/default.m3u to my favourites
after reboot works to perfection
Summary: It took me three days to get Pirate Radio to work. Lots of reading on the forum inbetween to get more understanding of the phat-beat.

Other comments:

Loudspeaker terminals are lousy,
Volume + - react rather slowly

There is another topic on the forum “phat Beat - doesn’t work” ,and I wrote this procedure as a reminder. In my previous attempts I didn’t update and upgrade…

calleblyh


#12

So far I’ve stayed with Jessie, the full version. I find it easier to setup WIFI keyboard etc running the full Raspbian. Then last thing I do is switch it to boot to command line.

I’m not all that fussy for those speaker connectors either. I use a screwdriver to gently depress them, like you do to remove the wires, when inserting the wires.

I just copy my playlist.m3u file to the Boot partition. The one visible from a Windows PC. It then gets moved and becomes the new default. That way I can do it up with notepad and just copy it to my SD card from my windows PC. No having to sudo nano etc.


#13

I suspect this is my problem for no sound. But how the heck do I get the speaker wires out of the phatbeat “slots.” Thanks


#14

To remove the wires you gently press down on the tabs on the holders until the wire can be pulled out. They should come out easily when enough pressure is applied. I use the tabs to insert the wires, instead of just forcing them in.


#15

Thanks. Got them out, stripped the covering back to expose more wire - still no sound.


#16

I did an install a couple of days ago and got no sound, other than the pop when it powers up. Tried all manner of things with no luck. Then refreshed an older image I had made of a working install I had made but forgot about. That worked. I “think” there may be something amiss with the vlc radio one line installer.
Try running “sudo systemctl stop pulseaudio” then try “speaker-test -c2 -t wav”. That will tell you if the pHat Beat is working.


#17

Now I get this error:

pi@raspberrypi:~$ speaker-test -c2 - t wav

speaker-test 1.1.3

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
Using 16 octaves of pink noise
ALSA lib pcm_meter.c:677:(snd_pcm_meter_add_scope_conf) Cannot open shared library /usr/local/lib/libpivumeter.s
o
Playback open error: -2,No such file or directory

The file is there - several times (0.0.0.) but the file is 0 size


#18

Have you checked both speaker outputs.? On one of mine phatbeat’s there was a malplaced amplifierchip


#19

I have no idea what that error message means? @gadgetoid might be able to help though.


#20

I reset the speaker wires and rebooted and got this

speaker-test 1.1.3

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 96 to 1048576
Period size range from 32 to 349526
Using max buffer size 1048576
Periods = 4
was set period_size = 262144
was set buffer_size = 1048576
0 - Front Left
1 - Front Right
Time per period = 11.123390
0 - Front Left
1 - Front Right
Time per period = 11.121928
0 - Front Left
1 - Front Right
Time per period = 11.164433
0 - Front Left
1 - Front Right
^C
Time per period = 11.253653

Does this mean both the red and black are seated correctly?