Pirate Radio - hot speaker, no VU meter and full volume


#1

I too have taken delivery of the Pirate Radio kit and have had several ‘goes’ at getting it working as an internet radio. Hardware no problem. Internet connection working OK. Today (6Apr2017) reloaded and rebooted software from Pimoroni’s web site. Speaker is on full volume and the magnet at the back is too hot to handle - wow! Volume + and – side switch controls turn the volume on/off, and when on (full volume) I hear a station but it is too distorted to make it out. VU meter not lit however the LEDs have worked in a previous software build. I seem to be able to change stations or internet sources using the side switches. Where do I start to unpick these issues? At this level I would class myself as a beginner although I am familiar with command line screen and instructions.


#2

the vlcradio script - which I guess is what you are referring to as ‘software from the website’ - sets up button control including volume control, and starts around 35% of full the very first time (after that, whatever you had on exit will be recalled).

… are you saying the initial volume is uncomfortable and/or the buttons don’t do anything when pressed? or are you using some other setup method as many aspects in your report don’t correspond to the expected behaviour.

It could also be that the soldering on the pHAT is not adequate, which would render either buttons or VU non-functional - that would be my first port of call, as well as run the tests included in the pHAT BEAT repository.


#3

Hi Crew,
Today I first ran in the command line 'sudo apt-get update && sudo apt-get upgrade ’ - reboot - to ensure the Pi Zero W was working at 1GHz. I ran ‘curl https://get.pimoroni.com/vlcradio | bash’ - reboot - (taken from the VLC Radio Project web page) using the command line interface to upload the correct settings and relevant software. After this the symptoms I describe are present.
The initial volume is damaging the speaker so I suspect it is set to 100% - It is so loud the diaphragm visibly shakes and the sound is mostly unintelligible. Pressing the - and + buttons just turn off and turn on the sound. The speaker is alarmingly hot as though there is a dc current element passing through it - to me that would indicate the audio o/p capacitor had failed.
This is not the first time I have tried to load software. Previously I had loaded ‘curl https://get.pimoroni.com/phatbeat | bash’ using the web link from ‘One line Installer’ on Pimoroni’s Pirate Radio - Pi Zero W Project Kit shop web page. This had the effect of setting the volume to max and running the VU meter LEDs but no internet radio except I could get the radio to burst into life for about 1 second after pressing the ‘change channel’ control. This is probably when the volume was set to 100% and the is now setting stored.
I’ll physically inspect the soldering on the pcb and I will try the audio tests from the pHAT BEAT repository you describe. I have seen references to the repository so I assume I navigate using the command line interface after which I hope the next steps are self explanatory.
Many thanks, Helix


#4

the vlc user settings are stored in: /home/pi/.config/vlc/vlcrc… delete that file and the volume should drop back to comfortable level after a reboot. Still, it is not normal that the buttons turn volume on/off, unless if you hold them down (which is a vlc thing IIRC) - they should step in 10% increments.

but, yes, if I follow, you need to press FF or REV to kick the radio in, as documented here:

you should also find the test in '/home/pi/Pimoroni/phatbeat/test/ on your system. Run the test.sh file to check through all functionality of the phatBEAT. Even volume at max the output should not rattle the speaker or feel overly loud.