Anyone using a phatdac and amazon alexa on a pi zero?


#1

I was able to load up amazon Alexa on a pi 3 using default sound, but my goal is to put it on a pi zero w and enhance the sound using a phat DAC for audio out. Sorry if this is an amazon question but I fear I may be creating a conflict on the pi zero by using both a phat DAC and a Sony play station eye as soundcard hardware. The eye serves the need for a mic. Since its working on the pi3 I am afraid to mess up the current config so before I dabble any further I figured I would ask if this is even possible? If you haven’t already figured I aspire to know enough to be dangerous.


#2

For more information - All things appear working on the surface if you were looking at the logs, albeit- no audio. I have experimented with multiple configuration options in my /etc/asound.conf file, yet none seems to work. Alsamixer shows both the soundcard and the play station eye, and when I boot up the pi zero and ssh into it, I get a green light when i use "sudo systemctl status AlexaPi.service -l"
my log file can be found using this link:
http://www.alsa-project.org/db/?f=23a9b860132026291878f08a37b22e44ebbdcf92


#3

Have you tried getting the setup working on the Pi3, i.e using the DAC as output… not sure this could be related to processing power… maybe…

… anyhow, I don’t see any reason why that wouldn’t be possible. What was the purpose i.e what did your custom asound do in the case of the working setup on the Pi3, can you post it?


#4

I was thinking it could be a power issue as well but i did not fare any better on the pi3b with a phat dac and ps eye. Interestingly, in my haste to bring things back over to the Pi3b i missed a critical step of installing Alexa in the /opt directory. I did have audio then, but of course I did not have Alexa working so I went back to the drawing board.
I even tried installing pulse before Alexa with no luck.
Unfortunately, I will have to take a few days off as my sd card snapped after i forgot to remove it from the pi3b before encasing it. For what it’s worth, I have been toggling back between the two asound configurations:

pcm.!default {
type hw
card 0
}
ctl.!default {
type hw
card 0
}
#-or-
#pcm.default pulse
#ctl.default pulse


#5

I’m not convinced you need an asound file at all. At least at the most basic level.

… I can try to it but it would help to know which Alexa API you are using, I belive there are several out there.


#6

Just for giggles, over the weekend I took a stab at the Google AIY version. Had it working with an added benefit that I could see a text version of my questions appear on the screen, and I can safely say the microphone and google were very accurate, and audio out sounded nice. but this runs using a keyboard using full Jessie, and my preference would be to use Jessie lite, headless.
To answer your question, after enjoying what I saw from Google - I found the ultimate. I am using this codebase: https://github.com/alexa-pi/AlexaPi and I sourced it from this project:
https://www.hackster.io/xtools/assistantpi-74b772
But it seems I end up at the same juncture: Instead of an asound.conf file in /etc/, I have my config file set for Pulse in my /etc/opt/AlexaPi/config.yaml as input_device: “pulse” output: “pulse” and output_device: “” as the instructions state. No Errors, but no audio either.