Anybody suddenly seeing microSD slowness on RPI5?

I’ve got 3 PI5s now, two run exclusively from SSD instead of microSD but one arrived only a couple of days ago.
Bought a PI5 8GiB 43 days ago to run as my main node, bought a PNY 128GiB microSD to just put an image on to flash the SSD, no problems worked, didn’t use the microSD after getting the image onto the 500GiB SSD I bought with the Pimoroni board. Let’s call this PI-A
Bought another PI5 about 21 days ago for a very specific task to run off microSD which didn’t need storage so I bought another PNY 32GiB microSD and it’s been running from that. Has had several reboots and updates… worked fine up until what I’m about to mention. PI-B
Did some updates including a Kernel update in this time in between as I saw them arrive
Bought another PI5 this week, same spec as the original with a Pimoroni NVMe board and 500GiB SSD, used the original PNY 128 GiB microSD to get it started and updated everything on the microSD before starting (so everything now latest Kernel etc.).
Booting a couple of times to do some preliminaries and then I was getting 7 flashes out of the LED meaning that the Kernel image couldn’t be found… didn’t think too much of it at that time and rewrote the microSD and was able to boot and install onto the SSD. No problems since on that node. PI-C
I then started to rework things a bit with regard to PI-B in terms of configuration as I needed to move things around and it appeared to be dead on a reboot… leaving it for a while it finally let me login (I don’t have a working HDMI cable, the one I bought is crap and doesn’t seem to register on the PI - done various reading about that, all annoying, will buy another one at some point).
I’m observing 1) A fairly unused PNY microSD card corrupting very quickly and 2) on PI-B a huge delay in access times with various dmesg reports showing ‘mmc0: Card stuck being busy! __mmc_poll_for_busy’ or read errors that make the system take about 5 mins to be reachable on network instead of the initial ~15 seconds when it was first installed.
So this is two different PI5s observed on, one with the Pimoroni NVMe board and one without and two different microSD cards - each with very low usage.

Just wondering if anybody else has seen the same?

I’ll try rolling back the Kernel version at some point to see if it was indeed related to a change recently released. Noting I’ve tried kernel8.img as well which has the same issue on PI-B.

PNY (microSD at least) seem to show favourably on the closest thing I could find to a compatibility DB and I find it surprising that two farily little used cards should start behaving like this.

All PI5s are running this rev Kernel btw.

andrews@rvp1:~ $ uname -r
andrews@rvp1:~ $

Just reviewed the apt update history and no, there actually doens’t appear to be an update to the Kernel since I installed PI-B as I thought it had done.
Reviewing changelogs now, there are a few packages including rpi-eeprom that got updated on the 9th April.

OK, firmware rolled back, same issue - time for a trip down to Argos to pick up a Sandisk High Endurance card to compare.
New card is booting all my services in about 17 seconds now… fingers crossed it survives better than the others but I’ve bought an Endurance one and disabled swap to further reduce wear.

In the past I always had once in a while problems with Micro SD-Cards and the Pi. For example, I own a 400GB SD-Card, that worked for years in a Pi3A+ with heave IO (a PVR-machine). It suddenly stopped working an the Pi refused to boot. Cleaning the contacts and wiggling around did not help.

But it only stopped working on this specific device. I am now using it with a Pi5 (desktop) without any problems. And I also have no problems elsewhere. And the Pi3A+ is happy with a different card.

So this is nothing surprising. It is only hard to explain.

I have the same issue, I am using a Samsung EVO card 512 Gb to run Home Assistant. The rbpi is not very active since I planned to move my Rbpi3 workload to it, just did not find the right to do it at the moment.

I noticed yesterday that it was very slow; so I decided to give a reboot a try. First boot was stuck and tried a cold boot. Forgot about the device and noticed the root FS was mounted RO this morning (with failed services).

Gave it another reboot (after remounting / as rw again and doing a full upgrade); boot was still slow; but not as slow as before.

[  625.508925] I/O error, dev mmcblk0, sector 46336064 op 0x0:(READ) flags 0x80700 phys_seg 2 prio class 2
[  784.776171] mmc0: Card stuck being busy! __mmc_poll_for_busy
[  836.600569] Bluetooth: RFCOMM TTY layer initialized
[  836.600583] Bluetooth: RFCOMM socket layer initialized
[  836.600591] Bluetooth: RFCOMM ver 1.11
[  971.646017] mmc0: Card stuck being busy! __mmc_poll_for_busy
[ 1047.854264] I/O error, dev mmcblk0, sector 8338144 op 0x0:(READ) flags 0x80700 phys_seg 1 prio class 2
[ 1071.224354] mmc0: Card stuck being busy! __mmc_poll_for_busy
[ 1102.959903] mmc0: Card stuck being busy! __mmc_poll_for_busy
[ 1240.188763] mmc0: Card stuck being busy! __mmc_poll_for_busy
[ 1272.211202] mmc0: Card stuck being busy! __mmc_poll_for_busy
[ 1407.893300] mmc0: Card stuck being busy! __mmc_poll_for_busy
[ 1528.988716] mmc0: Card stuck being busy! __mmc_poll_for_busy
[ 1560.944661] mmc0: Card stuck being busy! __mmc_poll_for_busy
[ 1592.981889] mmc0: Card stuck being busy! __mmc_poll_for_busy
[ 1652.354765] I/O error, dev mmcblk0, sector 19054880 op 0x0:(READ) flags 0x80700 phys_seg 2 prio class 2
[ 1677.571429] I/O error, dev mmcblk0, sector 19055136 op 0x0:(READ) flags 0x80700 phys_seg 2 prio class 2
[ 1761.933157] mmc0: Card stuck being busy! __mmc_poll_for_busy
[ 1793.933042] mmc0: Card stuck being busy! __mmc_poll_for_busy
[ 1826.190463] mmc0: Card stuck being busy! __mmc_poll_for_busy
[ 1858.159340] mmc0: Card stuck being busy! __mmc_poll_for_busy

This is a hardware problem. You should try it with a different card. As described above, this does not imply that your card has a problem. It might be just the specific combination of this card with this Pi5.

Do you really need 512GB for Home Assistant? I always prefer the smaller cards, mainly because backup and restore is so much faster with them. What I also always do is to separate the system partition from the data partitions. But for this you need advanced Linux know-how, since the default setup just uses up all the space on the card.

No, but I also do GStreamer development and packaging, having a larger SSD can be handy for media processing and testing, I might have gotten carried away. TBH, I never had a problem (1-3 versions) with my rbpi in the past, so I just dumped the system on the SSD card without much thought.

I think I might have just enough background to partition my SSD :-)

I needed to buy a couple SD cards anyway; I just wanted to confirm that I had a similar problem.

A bit confusing: you are talking about a “SSD card”?! Your log shows problems with a micro-SD card, not a SSD.

1 Like

My mistake, the system I’m working on for work (not rbpi) is eMMC, SSD based: power of habit.