Read-only micro SD card?


#1

So I bought a nice shiny 32GB card today and successfully moved the data (Raspbian OS) from my old 8GB card in my Pi3 to the new 32GB using the Raspbian SD card copier tool. The 32GB card works fine. Since I was copying cards I figured I’d clone another card onto the old 8GB card I’d just removed from the Pi 3. The data (Raspbian OS again) moved fine using the same tool but when I boot the card in a Zero the card now seems to be in read-only mode and none of my changes are saved. I can still burn Raspbian images to the card, but any attempt at formatting comes up with an error about the card being read only.

Is there any way to fix this or is the card duff?

I only bought the problem card from Pimoroni back in Feb, would it still be under warranty? It’s a Samsung branded NOOBs card if that helps?


#2

I’m afraid you lost me half way through your post. What card is locked in read-only mode and what data did you transfer to it and via what method?


#3

Edited my original post - sorry if it was a bit confusing wrote it after an hour or two of trying to get it working.


#4

Welp, just spent another two hours trying to get the card working to no avail. Must have cocked something up when copying. Guess I’m buying another.


#5

I have the same problem…

So far I tried with these tools :

  • Diskpart on Windows
  • Disk manager on Windows
  • HP USB tool on Windows
  • SD card formatting tool from the sdcard website on Windows
  • Gparted on Linux
  • 2 different cameras

None worked… Quite disappointed