Raspberry pi is blowing SD cards?


#1

I just bought a Rapsberry Pi 3 with case, the noobs SD card and a Skywriter Hat but when I put it together I couldn’t get it to start. I took out the micro SD and put it into my Windows PC thinking I’d try re-installing the OS but the PC couldn’t see the card.

Thinking it was a faulty SD card I bought a new SD card, put it in my Windows PC and installed Raspian, then tried it in the Raspberry Pi. This started to boot but stopped with a kernal panic, the message was something like it couldn’t sync to a non-existent block. I decide to try noobs instead but when I put the SD card back in my Windows PC the PC couldn’t see this card now.

It looks as if this Raspberry Pi is blowing SD cards. The next obvious test would be to disconnect the Skywriter Hat but I don’t want to keep doing these tests if they are going to blow up SD cards every time. Any idea what I should do next?


#2

OK, forget most of that. I just tried the SD card again (after numerous other tries) and this time the PC recognized the new card. I re-installed Raspian and now it is working. The previous problems were probably just Windows being a bit flakey.

I still can’t get the PC to recognize the original SD card, maybe this has been blown somehow or was faulty on delivery.

Is there any way I can delete this thread?


#3

See if the SD card shows up in Disk Management. Or diskpart. If you can access it via diskpart try doing a clean command on it. Then see if you can partition and format it. I’ve had only one SD card actually fail on me to the extent that its not usable. Most of the time its just corrupted and windows can’t see it.


#4

I can make it disappear if you wish, but it’s not doing any harm being here.


#5

I just didn’t want to clutter up your board with a post that turned out to be mostly my mistake. There is still some issue with one of the SD cards so it might be best to leave it. I’ll leave the decision up to you.


#6

Disk Management doesn’t show it. If I have the SD card inserted then Disk Management takes a long time to start and it shows the removable disc has having no media. If I try diskpart j: then it opens and closes a window so fast I can’t see any messages in it,

I’ve tried booting my PC into Linux (it’s dual booted), Linux does not see the disk and gparted can’t see it either.

I don’t know if it’s worth sending it back to Pimoroni. If it is dead there’s no way of knowing if was always bad of if I did something to break it.


#7

Well we have no way of knowing either, so you might as well send it back! I don’t believe it’s particularly easy to fry an SD card, and it doesn’t sound like you’ve done anything wrong.

My next question was going to be where did you get it, but you’ve answered that already :D


#8

OK, I’ll send it back to your returns department with a letter explaining the problem.

You say it’s not easy to fry an SD card, so I suppose it’s safe to swap them in and out if you want to run different OS distributions at different times on one Pi?


#9

“so I suppose it’s safe to swap them in and out if you want to run different OS distributions at different times on one Pi?”

As long as the Pi is off, yes. I do it all the time. I re flash the cards all the time too. Been using RPi since the beginning and never broke an SD card with one. But then I only use scandisk cards brought from outlets I trust, IE direct from Amazon.

2 golden rules: 1 Shutdown the RPi correctly, don’t just turn the power off. 2 Don’t remove the SDCARD with the RPi powered on.


#10

@ Richard I do the same thing. I swap cards around, reflash etc. I’ve only had one card actually fail, which I think it would have anyway regardless of what device it was in. Just a dud card is all.


#11

I had a old NOOBS microSD card get stuck in some sort of ‘readonly’ mode once. Not sure how that happened.


#12

Quite a lot of SD cards (mainly larger ones) use a little “read-only” switch on the side of the card that prevents the writing of data as a safeguard measure. If the NOOBS install card has one, just double check it’s not switched on!


#13

I haven’t seen that switch on a Miro SD card. My card adapters (Micro SD to SD) have them though.


#14

Yeh that’s the thing, there was no switch on it, but the card was convinced that it was readonly, tried re-imaging in Windows, Raspbian, etc. but couldn’t replace the existing image, so binned it. I’d guess some power-related shenanigans caused it.


#15

Probably; either that or the switch was still “there”, but had just been removed during production, so the software side of the read-only function had been accidentally enabled by a power surge or what not.
I’m not sure about Micro SD cards, whether they actually still have the circuity or it has just been removed completely. I suppose it depends on the manufacturer!


#16

Yeah, it was a microSD, so I assume some software readonly got set on the partition, and there was no way to unset it. Still, not the most expensive issue to have.


#17

My card that failed went from 8 gig to showing as only 30 meg. I could access it via diskpart but any attempt to partition or format it failed.