Deleting partitions on a NOOBS card

I bought a NOOBS card back in 2016 which worked fine, until I somehow messed it up badly (don’t ask!). It doesn’t boot and doesn’t recover either.

I now want to wipe the card and install Raspbian Buster as as per the official instructions to use in a RPi3. I want to use either Linux command line tools or the imager. But both these want a clean SD card, and I can’t seem to wipe this NOOBS SD card. I have tried

  • GParted
  • fdisk
  • diskpart (Windows) with Admin command prompt
  • inserting it in an Andriod device and trying to clear it (it’s not detected)
  • Paragon Partition Manager (Windows)
  • SD Association’s SD Card Formatter (Windows)

All tools report success upon completion, but the partitions and the data remains. I am utterly mystified by this!

What are your suggestions?

The Pi foundation tool will wipe the SD card, repartition, and reformate it for you.

The Raspberry Pi imager tool (on both Linux and Windows) reports “Error removing existing partitions”. It was the first thing I tried, hence all the other methods listed above.

Ok, fair enough. It sounds like you have a defective Micro SD card.
Is it flagged as Read Only maybe?
In disk part, “clean all” is what I usually do. You want to make doubley sure your running it on the correct drive though.
If all those utilities failed, something must be mucked up on the SD card, hardware wise.

Yes I’ve tried “clean all” in diskpart, no joy.

I was suspecting the card might be dodgy. Would also explain why the OS won’t boot!

Thanks for all the help!