Are Octocam Instrutions in error?


#1

My Octocam fails to boot. It just spits out a bunch of text, then sends a Kill signal to all processes and thendoes it all over again.
Is there a couple of errors in the instructions on the motionEYE web page?

  1. It says to put the wpa_supplicant file in the boot partition. Do they mean the boot directory?
  2. The wpa_suppplicant file they give on the web page contains the line, “Country=GB” is this correct and or required when you are in a different country?
  3. There is a line that says,
    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev

but elsewhere on this forum I see the line,
ctrl_interface=/var/run/wpa_supplicant

which one is correct? (BTW there is no ref to any user in group netdev in the passwd file altho there is a netdev group in the /etc/group file.

Thanks,
pgmer6809
PS if you ssh into the octocam whihc user/passwd combo does one use?
pgmer6809


#2

That’s one thing that drove me nuts. With the stock install it looks for an Ethernet connection, and if it can’t find one it just endlessly reboots. Even if you have a monitor keyboard an mouse connected. You can’t get in to setup your WIFI? Granted that’s not Pimoroni’s fault, it still drives me bonkers though. And if you get your wpa_supplicant wrong, same thing will happen, it just endlessly reboots.

What I did was plug this in, https://shop.pimoroni.com/products/three-port-usb-hub-with-ethernet-and-microb-connector and used an Ethernet cable so it was on line. Then I used the angy IP scanner to find it so I could log in and setup my WIFI. Once I did that I removed the USB Hub. I already had that hub on hand. I’ve found them very useful for setting up Pi Zero’s.

The country code changes depending on where you live, mine would I believe be CA < has to be capital letters. For me GB would work OK as they use the same 10 channels. Some country codes I believe open up channel 11, something like that.

That reminds me, I’ve been meaning to go look at a system I set up manually to see if there is a wpa_supplicant I can just copy to a thumb drive. Any time I’ve ever tried to edit one by hand it didn’t work, I always seem to get something wrong.


#3

I didn’t try to SSH in, I just typed the IP address into Internet Explorer.


#4

Yeah MotionEyeOS has a long saga of bug reports and issues because of its completely terrible WiFi setup procedure. If you have a GitHub account I’d suggest throwing a thumbs up at this suggestion - https://github.com/ccrisan/motioneyeos/issues/1421

Your only course of action is to reflash MotionEyeOS and start again, making doubly sure to get your SSID and password correct and make sure you use an editor like VSCode that doesn’t drop windows-only linebreaks into the file. One simple mistake and it’s an unrecoverable reboot-o-rama :(

Believe me, I ran into this issue and couldn’t even fix the WiFi by delving into the internals and manually editing config files from a host Linux computer. I was dumbfounded!


#5

The POST comments do not help much.

Update: If I boot the Octocam kit using a wired LAN donl;e it works after a fashion. I can ssh in, and I can point my browser at its IP address and see the camera output. It crashes after about 15 mins though.

I have copied verbatim the wpa_supplicant file from a working Raspbian PI-3 kit, but the Octocam still fails to boot with that.

One question not answered in the post comments is where to place the wpa_supplicant file. In the boot directory on in the root directory of the boot partition (and which partition is that? there are 3, one FAT and two Linux)

Thanks,

Greg.


#6

It’s the root directory of the /boot partition, same as Raspbian. I’d have expected a working wpa_supplicant.conf from an existing Pi setup to work, but it wont if you try and replace it after a failed boot. You only get one shot.


#7

What I did was hook up an ethernet connection for the first boot. Then I used the Angry IP scanner to find it. Entered that IP in IE and logged in as admin. Once you log in as admin and toggle on the advanced setup menu, the WIFI setup menu is there. That’s a lot easier (once you find it) than the manual wpa_supplicant option. Once I setup my WIFI, I unplugged my ethernet cable and rebooted.
Mine didn’t crash on me. Several instances where it appeared to lock up but if I waited long enough it came back. This usually happened after changing settings. And on reboots after changing settings.
My video was really choppy and lagging big time on a Zero W and original version 1 camera. The motion detect didn’t seem to work all that well either. Really hit or miss?
My only real plus comment is at least it streams locally over my network without having to go to the cloud first.


#8

Update: During the boot process the messages on the screen do not show MotionEYE even trying to start wifi. I goes to start wired network and if that fails boots endlessly.
Update: Booting with a LAN dongle does get it to boot. The messages on the screen show the usual net services (sbd, mnbd etc) starting. I can ssh in, and use the cmd line for about 15 mins before it crashes.
Update: The instructions on from Pomoroni seem oriented to Windows users. Of course I am using LInux. I have discoverd thru trial and error that the boot partition is mounted over the boot directory at startup, and I have discoverd thru trial and error which partition that is. (the FAT partition) so I have placed the wpa_supplicant file in that partition.
Update: When I use Firefox as a browser to go to the OCTOCAM IP address, I can see a camera window and a ,mostly black screen. Someone here posted logging in as ‘admin’ but the change user icon/menu won’t let me change users, and there is nothing under the ‘menu’ icon either.
After about 15 mins the OCTOCAM crashes.
The most recent crash mentioned something about a udev segfault.

Is switching to RASPBIAN an option for this kit?
pgmer6809


#9

Click the people icon top left to switch user. Then type in admin with no password. Toggle the remember me too if you want. Then click login. Then click the other icon with the three vertical bars. Click the general settings then toggle advanced settings to ON. If it prompts to reboot let it. If it does reboot go get a cup of coffee or something while you wait for it to connect again. It may appear to lock up, just wait it out.
Once you have advanced settings enabled scroll down to network and toggle Wireless Network ON, and enter your info. Then reboot and unplug your ethernet cable. Your IP address will likely change so you’ll have to find its new one to log in again.


#10

You can use Raspbian directly, yes, but would need to find a way to stream the camera feed.

I’m surprised you’re having so much trouble with MotionEyeOS now it’s up and running. What power supply are you using? (I can’t recall if there’s one in the kit)

My Octocam has been running stably for days- so this might suggest a problem with your power supply, your Pi, or perhaps overheating (it does get pretty warm) which likely wont be fixed by switching to Raspbian.


#11

Thanks for the feedback.
After much testing Pimoroni and I think I prob have a hardware problem. I can get the system to run for a period of time (2min-40mins) with most O/S: MotionEye, Stretch, Stretch Lite and Jessie, but the system HDMI output freezes sooner or later. Sometimes it reboots when that happens but sometimes the network stays up for awhile longer (it depends on the OS). The chip is sometimes just room Temp and sometimes hot to the touch.

Pgmer6809


#12

That does, indeed, sound like a hardware problem. Could still be a power issue, but if you’ve got it hooked up to HDMI you’d probably see the lightning-bolt-of-low-power at one point long before it gets unstable.