OctoCam Wifi Woes


#1

The OctoCam arrived today, and so this evening I’ve run through the building and set up of it.
However, after flashing the MotionEyeOS image, and creating the wpa_supplicant.conf file all I get when I power up the pi is a looping startup.
I see “starting spa_supplicant.conf: failed(brenfmac)” and “configuring wifi: no link” on a couple of lines of text, before everything is stopped and the pi reboots.

I’ve refreshed the micro SDcard so many times already, I’m not sure what else I can do.

TIA.


#2

Could you post the contents of your wpa_supplicant.conf here? (minus your password, of course) It’s most likely that you’re making a minor syntax error, or perhaps even missing a capital letter or two in your SSID. MotionEyeOS is ridiculously sensitive to WiFi configuration.


#3

It’s also worth ensuring that it’s also a plain text file, and not rich text. We’ve seen Wi-Fi configuration problems caused by that before. How exactly are you preparing the wpa_supplicant.conf file?


#4

Here’s the wpa_supplicant.conf file I created using the template on the tutorial page;

update_config=1
ctrl_interface=/var/run/wpa_supplicant

network={
scan_ssid=1
ssid=“VM450155-2G”
psk=“********”
}


#5

I used text edit on my MacBook.
Saved initially as a .txt file, then renamed it as a .conf file


#6

TextEdit on the Mac will save in Rich Text format unless you specify otherwise. You need to go to the “Format” menu and then click “Make plain text” to convert it to plain text. Then save it in /boot and try again.


#7

You mention saving in /boot, but when I put the MicroSD card into the Mac, I only see one partition.
When I’ve flashed previous cards for use in a RasPi I’ve seen /boot appear, but not with this Motioneye image.
I’d assumed there was no /boot partition with this image.

Now I’m wondering why I’m not seeing it.


#8

What’s the name of the one partition you do see, do you see files like config.txt and start.elf and kernel.img there?

Disclaimer: I haven’t played with MotionEyeOS much!


#9

Ah, sorry, I said /boot out of force of habit. Just drop it into the partition that appears. IIRC mine was called NO_NAME, helpfully.


#10

Phew! That’s where I had put it. The partition named itself 'No Name’
I’m going to refresh the card once again and give it another go.


#11

I’ve sorted it.
I suddenly remembered back to trying to write a CSS for a website - the " kept changing to a ” causing an issue.
That’s what it was here. I’ve copied and pasted the " from the tutorial and it works now :o)


#12

Yay! Glad you got it working. :-)


#13

note that you can force TextEdit to use sane quotation marks.

I HIGHLY recommend you start using some other editor to edit configs though - TextEdit has so many unhelpful defaults for this purpose that you will trip on another one soon enough again!


#14

Hi All,

I have been trying to get the SD card to mount properly after flashing the MotionEye OS image using Ethcher. I have tried different computers and different SD cards and sizes. I have even tried older versions of the software as well as using Win32 Imager. I dont know what else to try.

Thanks Blacko.


#15

having same problems… have booted to raspbian and wifi is working.
Using MBP Etcher TextMate 8gb Scandisk Ultra

conf

Any help much appreciated
Thanks