Audio Amp SHIM (3W Mono Amp) - Volume Control

I’ve recently brought an Audio Amp SHIM (3W Mono Amp) and have it working OK.

But I can’t find, for the life of me, a way to control the volume.

I’ve tried many options off Google to do it with MPC commands, amongst others.

It would seem strange for this product to have no volume control at all.

Thanks.

Thats digital audio, i2s (DAC) so I’m guessing you have to do that via i2s? On the Pi side of things? I can adjust it on my Pirate Radio that also uses i2c. I’m running an older version of Pi OS on that that still has and supports alsa. alsa is missing from current Pi OS versions and “might” be part of your issue?
Are you running from command line or GUI?

See Volume for Pirate Audio: Headphone Amp for Raspberry Pi - #3 by bablokb for a workaround. the Pirate-Audio uses the same DAC and this solution creates a soft-volume control.

Thanks for the responses. I’ve followed the advice to add the code to asound.conf but no luck. alsamixer still states that there are no controls for this device.

Sorry I might be missing something!

aplay -l shows

**** List of PLAYBACK Hardware Devices ****
card 0: sndrpihifiberry [snd_rpi_hifiberry_dac], device 0: HifiBerry DAC HiFi pcm5102a-hifi-0 [HifiBerry DAC HiFi pcm5102a-hifi-0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: vc4hdmi [vc4-hdmi], device 0: MAI PCM i2s-hifi-0 [MAI PCM i2s-hifi-0]
Subdevices: 1/1
Subdevice #0: subdevice #0

Do you have a .asoundrc in your home-directory? That will override any /etc/asound.conf.

Hi, not that I can see. I’ve looked around folders and found the following. I did install pirate-audio when I first tried this board.

/pirate-audio/speaker-and-mic $ more asound.conf


pcm.mic_hw{
    type hw
    card adau7002
    format S32_LE
    rate 48000
    channels 2
}
pcm.mic_rt{
    type route
    slave.pcm mic_hw
    ttable.0.0 1
    ttable.0.1 0
    ttable.1.0 0
    ttable.1.1 1
}
pcm.mic_plug {
    type plug
    slave.pcm mic_rt
}
pcm.mic_filter {
    type ladspa
    slave.pcm mic_plug
    path "/usr/lib/ladspa";
    plugins [
    {
        label invada_hp_stereo_filter_module_0_1
        input {
	    controls [
                50   # Cut off frequency (Hz)
                30   # Gain (dB)
                1    # Soft Clip (on/off)
            ]
	}
    }
    ]
}
pcm.mic_out {
    type plug
    slave.pcm mic_filter
}