Blinkt hat stopped working


#1

I have not had the Blinkt very long and not used it much. Now I have the scrollphathd and the blinkt on a mini black hat hack3r,which is connected to a pi Zero and the blinkt doesn’t work, but the scrollphathad does.
I have tried the blinkt connected direct onto the gpio pins of the pi zero, but it still doesn’t work.
The blinkt is installed with the curved ends facing away from me, towards the ribbon cable and the letters BLINKT are facing me as in the right way up.

Won’t 2 phats work or run on the same ribbon cable to an expansion board.


#2

2 pHats/Hats will work as long as there aren’t any conflicts with the GPIO pins they use.
You can check the pin outs here for conflicts. https://pinout.xyz/boards#


#3

So I have got the Blinkt board the right way on the black hack3r or have I?


#4

If you have the end of the mini hack3r with the ribbon cable attached farthest away from you, and can read the letters on the Blinkt it should be the right way up.


#5

Or to put it another way:
When I look at the min black hack3er board, the words are facing me the right way up, and the Blinkt board’s word or letters BLINKT are also facing me and the right way up. The curved corners of the blinkt board are facing the same way as the curved corners of the mini black hack3r.


#6

it sounds correct- how is the mini black HAT Hack3r connected to the Pi? The ribbon cable should jump over the Pi itself.


#7

Yes the ribbon cable is over the pi zero and as I said above the scrollphathd is working fine


#8

Was the blinkt working? I think I’d run the installer again.
curl -sS https://get.pimoroni.com/blinkt | bash


#9

It may be unrelated, but did you try using your 12v LEDs connected to the Blinkt! pins on this Pi Zero?

Did you make any modifications to the Blinkt! library which might cause it to fail?

Is any other software running that could be interfering with pins BCM23 and BCM24?


#10

@gadgetold, no the 12v LEDs were not connected to Pi Zero at all or ever, and only to the Pi 3


#11

@alphanumeric
I don’t know if it was working or not as I did not use it until now.

I have ran the installer again, and tried ‘python solid_colours.py’, but nothing happens, and only the cursor is showing under the above command.

When or after I do a ctrl C, it returns this:

Traceback (most recent call last):
File “solid_colours.py”, line 23, in
time.sleep(0.5)
KeyboardInterrupt


#12

Ok, just wanted to find out if it had been working and stopped working, or if this was the first time you tried to use it.


#13

Did you run that from idle (or other editor) or from terminal window?


#14

From a terminal window as with the scrollphathd.


#15

It’s possible that your Blinkt! is DOA. Unusual, though, since they’re not very complex products. Drop an email to support@pimoroni.com referencing this thread, and they should be able to get you a replacement.


#16

I have just sent an email to the address given.
Thanks


#17

Full path
python3 /home/pi/file.py
Just double checking everything. It does sound like its DOA.


#18

What does that do or for:
python3 /home/pi/file.py??


#19

Just an example. I save my python files in Home/Pi. To run one from the terminal window I have to type in
sudo python3 /home/pi/myfile.py
If I just type in myfile.py nothing will happen. Well actually I’ll likely get some kind of error message.
Sorry if I’m just confusing things, it sounds like you did have the file running. If you run it from an editor like idle3, you’ll get error messages (or should) when things go wrong. It’s how I test all my files.


#20

Just to let you know that I have not had any response from the support team on this matter after I sent an email with the relevant details etc.
I have just sent another email on the same subject, so we’ll see if I get any response.