BME680 installation stops

Dear reader.
Today I wanted to install a BME680 on a Pi Zero WH, The BME680 was taken from a setup with Pi Zero WH and Grow HAT, where it worked fine.

I did the following things:
-Attached the BME680 with jumper jerky to a Pi Zero WH
-Downloaded Pi OS Lite (release date 4th of March 2021)
-Installed it with Balena Etcher
-Did headless setup
-Changed password of user Pi
-Enabled I2C
-Installed GIT
-Ran curl | bash
-It freezes on installation for at least 30 minutes.

I did the above steps all again, and again the installations froze and stayed the same for at least 30 minutes. Normalle the whole installation is done in way less time.
Here is the output from the last try:

% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 38662 100 38662 0 0 159k 0 --:–:-- --:–:-- --:–:-- 159k

This script will install everything needed to use
BME680 Breakout

Always be careful when running scripts and commands copied
from the internet. Ensure they are from a trusted source.

If you want to see what this script does before running it,
you should run: ‘curl

Note: BME680 Breakout requires I2C communication

Do you wish to continue? [y/N] y

Checking environment…
Updating apt indexes…

Installing python-pip…
Extracting templates from packages: 100%
…Installing python3-pip…

Checking hardware requirements…

I2C already enabled

Checking packages required by I2C interface…
…Python 2 smbus installed and up-to-date
…Python 3 smbus installed and up-to-date

BME680 Breakout comes with examples and documentation that you may wish to install.
Performing a full install will ensure those resources are installed,
along with all required dependencies. It may however take a while!

Do you wish to perform a full install? [y/N] …

Does anyone has an idea what could be the problem, or at least reproduce the problem? If the problem is not reproducable it might be faulty hardware…

As far as I know the install should work even if the breakout isn’t connected. I’ve run them it in the past and realized after I hadn’t plugged in the breakout. Or forgot to enable i2c.
If you want to double check that its wired up correctly run
sudo i2cdetect -y 1 and look for a 76.
I kind of think it may be an Internet connection issue?
An alternate install method is as follows.
git clone
cd bme680-python
sudo ./

1 Like

Thank you for this method, it worked fine! Although I still wonder why the other method didn’t work.

That I don’t know? I have a couple of BME680’s and that curl bash has worked for me in the past. I haven’t run it lately though. It’s always nice to have a backup plan though for when things get funky and don’t work as planed.