Breakout garden weather project error

I’m setting up the weather example on two brand new raspberry pi zeros. The first one worked perfectly, but with the second one i’m getting the following error message, even after going through the github steps several times. Can anyone suggest a fix?

pi@raspberrypi:~/breakout-garden-master/examples/weather $ ./

This Pimoroni Breakout Garden example requires a
BME680 Environmental Sensor Breakout and a 1.12" OLED Breakout.

This example turns your Breakout Garden into a mini weather display
combining indoor temperature and pressure data with a weather icon
indicating the current local weather conditions.

Press Ctrl+C a couple times to exit.

Traceback (most recent call last):
File “./”, line 110, in
coords = get_coords(location_string)
File “./”, line 62, in get_coords
g = geocoder.arcgis(address)
File “/usr/local/lib/python3.7/dist-packages/geocoder/”, line 398, in arcgis
return get(location, provider=‘arcgis’, **kwargs)
File “/usr/local/lib/python3.7/dist-packages/geocoder/”, line 198, in get
return options[provider][method](location, **kwargs)
File “/usr/local/lib/python3.7/dist-packages/geocoder/”, line 389, in init
self.session = kwargs.get(‘session’, requests.Session())
AttributeError: module ‘requests’ has no attribute ‘Session’

Same hardware on both Pi’s? Running the same Python code?
If yes, what happens if you swap the SD cards between the two Pi’s?
If the problem stays I’d say its a hardware issue, if it moves it’s likely a software issue.

Great idea. Both setups are identical, so I swapped the SD cards and the error occurred on the first Pi this time, so I guess its a software issue. Perhaps I should do a clean reinstall of everything including the operating system?

Yes, my fall back when I’m scratching my head with a weird software error is to just start over fresh. Seond time around I pay attention to what shows on screen when running the install scripts.
Another option would be to clone the working card to the not working card.

1 Like

Hey - just wanted to report back that I did the test you suggested, cloned the SD card and … it worked! So thanks for that - you saved me hours of footling around.

Nice, now the fun part begins. Actually tinkering around with your new tech. =)
Also nice when its just a software issue. It’s no fun figuring it out, but it beats having to spend more money to replace broken parts, and or waiting for them to arrive.