Camera not detected

Hello, I have a raspberry pi4, with RasberryPi OS (32bit) installed from the imager.

I’m trying to get my camera to work. I’m following the instructions here:
Getting started with the Camera Module - Introduction | Raspberry Pi Projects

when I reach the instruction:

Select the Interfaces tab and ensure that the camera is enabled :

“camera” isn’t appearing in the list. I’ve checked and double checked that the cable has been connected properly, but I’m stuck. What might stop the camera from appearing? The camera is new, so I’m hoping not faulty.

Anything I can try to check?

Thanks in advance

with the pi off, step by step,is important! , make sure the ribbon cable is install correctly into the Camera and the Pi, correct connection is very important ,it was the error I was making when first using mine a few yr’s ago.

If your using the latest Pi OS release that interfaces tab has got a redo. It might be listed as CSI, and or be farther down the list. I’ll fire up my Pi 4B latter on and have a look see. Even with no Camera attached, the option to enable the interface should be there.

Thanks - I’ve tried refitting the cable lots of times. I don’t think that’s the issue. Thanks for the suggestion though, much appreciated

Thanks alphanumeric - my list is as follows
Serial Port
Remote GPIO

No camera or CSI - interesting that you think it should be there regardless of the camera being added. interested to hear back from you to see if your menu is dependent on the camera being plugged in or if it is just there as standard.

Again, thanks for taking the time to reply, much appreciated

Sorry for the long delay. It’s not listed in interfaces on my Pi 4B running Bullseye. I’m going to boot up my 3B+ that’s running Buster and have a look see.

It’s listed at the top of the list on my 3B+ running Buster. No camera connected to that Pi.
I have a bunch of cameras setup here, all are running Motion Eye OS though, which has the camera enabled by default.

OK - so I’m going to assume that the camera doesn’t appear in the list for RP4.
I continue with this site:
([](https://How to control the Camera Module with Python code))

I add the following code into Thonny - I save the code as and run it:

from picamera import PiCamera
from time import sleep

camera = PiCamera()


I get this in the output:

mmal: mmal_vc_port_enable: failed to enable port vc.null_sink:in:0(OPQV): ENOSPC
mmal: mmal_port_enable: failed to enable connected port (vc.null_sink:in:0(OPQV))0x243acd0 (ENOSPC)
mmal: mmal_connection_enable: output port couldn't be enabled
Traceback (most recent call last):
  File "/home/pi/Documents/Camera/", line 4, in <module>
    camera = PiCamera()
  File "/usr/lib/python3/dist-packages/picamera/", line 433, in __init__
  File "/usr/lib/python3/dist-packages/picamera/", line 512, in _init_preview
    self._preview = PiNullSink(
  File "/usr/lib/python3/dist-packages/picamera/", line 558, in __init__
  File "/usr/lib/python3/dist-packages/picamera/", line 2210, in enable
  File "/usr/lib/python3/dist-packages/picamera/", line 184, in mmal_check
    raise PiCameraMMALError(status, prefix)
picamera.exc.PiCameraMMALError: Failed to enable connection: Out of resources

Does any of that make sense to you?
And no problem at all with the long delay - not as long as mine to reply to you - I apologise in advance of my slow replies, which may be delayed by a day sometimes. Sorry :)

I can’t make any sense out of that message. Above my skill level. I’m thinking this is a Bullseye issue? Might be worth using the Buster (Legacy) option when imaging your SD card.

This may help? No harm in checking.
Use Picamera with Raspberry Pi OS Bullseye

1 Like

So, make sure it’s enabled in raspbi-config as “legacy camera” under “interface options”.

Why on earth they feel the need to put this in a tedious video instead of just writing, you know, words - especially when they rush through the most important part (which menu it’s under) so fast I had to pause and rewatch several times.

< /grumpyoldman >

1 Like