Is it possible to get a Pi Camera 3 working with Raspberry Pi 4 with Buster OS

Hi,
I recently purchased a Raspberry Pi Camera Module 3 from Pimoroni. The device I wish to use it with is a Raspberry Pi 4 8GB running Raspberry Pi OS (Raspbian GNU/Linux 10 (buster)) in an Argon One M.2 case. One function of this device is as a CCTV with a USB web cam using “motion” to capture video when movement is detected. However, the video quality is pretty rubbish using the webcam, so I decided to purchase the new Pi Camera Module 3 to improve it (and reduce processing power as it currently gets very hot!).

I followed the following getting started guides:

However, the camera is not detected. When I run the command
vcgencmd get_camera
I always get the response
supported=1 detected=0
Which is the same as if the camera is not plugged in at all. I have checked the camera cable is the correct way round on both ends. I have enabled the camera and I2C in raspi-config interfaces and added the following line to /boot/config.txt
dtoverlay=imx708
I have not yet tried the camera on other Raspberry Pi devices (which I have a few of). The device I want to use it with has other software running on it that I have not yet tested with Bullseye, so I am not ready to upgrade to Bullseye.

The new cameras will only be supported by libcamera. Does Buster have that?
New Camera module 3 autofocus/HDR camera thread - Raspberry Pi Forums

On the page:
(second link in original post as I can’t add it again?)
" Users running Buster will need to install one of the libcamera-apps packages first and then configure their /boot/config.txt file with the appropriate overlay for the connected camera. Be aware that libcamera and the legacy raspicam stack cannot operate at the same time - to return to the legacy stack after using libcamera you will need to comment out the dtoverlay change you made and reboot the system."
I installed libcamera using the following command:
sudo apt install libcamera-apps

next steps to try would be on a different board if available

failing that, with a multimeter:
check continuity on the cable
check power is getting to the camera module

The camera works fine with my Raspberry Pi 4 4GB that I have at home with Bullseye on it, using the same cable connected the same way. raspi-config interfaces legacy camera set to no and I2C set to yes. The Argon One M.2 case is not very camera friendly as I had to move the fan slightly to allow the cable to exit the case, maybe the cable is being restricted by this, but I don’t think so as it will slide in and out when the case is built up.