Can’t seem to get Inky Frame 5.7" to work (first time user)

Just got the Inky Frame 5.7 kit today (yay!) and followed the instructions – put the SD card in, attached the battery etc. – , but I can’t seem to figure out how to get it working.

If I simply turn it on, the WiFi and Flag LEDs blink seemingly randomly. If I then press any of the A-E buttons, any button I press lights up and stays on; so I can have all the A-E buttons on at the same time.

If I plug it into a laptop with Thonny installed, I don’t seem to get a connection either. dmesg detects nothing when I plug it into or out of the USB port.

All the time, the eInk display stays exactly the same picture it did out of the box:

What I tried and seemed to make no difference:

  • press the Reset button (it did seem to restart the system though, as the lights stopped)
  • press the BootSel button
  • re-attach the battery
  • re-attach the eInk screen connector
  • switch the USB cable for one that I know works
  • added my main user to uucp group and restarted the laptop
  • installed MicroPython (through AUR) on the laptop
  • switch the host laptop – I get the same results whether on Slimbook w/ Arch, Dell w/ Fedora or ThinkPad w/ Windows

I am a bit at a loss what to do.

For anyone else getting into the same issue:

  1. triggering a factory reset,
  2. flashing a new MicroPython,
  3. (and the Pimoroni examples)

fixed it for me.

As described in: