New Inky Frame 5.7 Unresponsive

Hey folks,

I’ve just unpacked a new Inky Frame 5.7 with the accessory kit. I haven’t been able to connect via MicroPython, or indeed to see any sort of activity on the board at all, either with battery power or connected via USB. I’ve tried several USB cables and USB power sources, as well as the “hold down the boot button and press the reset button” maneuver. Help would be appreciated.

We only started pre-loading Inky Frame 5.7" relatively recently, so it’s possible that you might have got one without MicroPython / examples - getting connected to the board with Thonny would be the way to check though.

Normally holding down BOOTSEL and pressing reset to enter DFU mode does something, so it might be worth trying with a different computer? If you’re using Windows you could check Device Manager to see if anything shows up when you plug it in?

I tried with a different machine with a built in USB-A port and that was able to connect. I think Thonny was having trouble with my Macbook’s USB-C to USB-A adapter.

1 Like