Can't get Trackball breakout to work as mouse on rasbian

Hi I want to use trackball as a mouse on my raspberry pi, ive tried to follow instructions on github but i can’t get it to work, Im new to raspberry pi and I don’t have any knowledge of programming, im trying to learn bits as i go along.
If anyone can help me with easy to follow instructions i would be grateful thanks.

What version of Pi OS, Bullseye, Buster, etc?
A link to the guide your following would help.
I have gotten mine to work in Buster, having issues in Bullseye though. works for me but sudo ./ gets me errors.
trackball-python/examples at master · pimoroni/trackball-python (

Hi I tried instructions on github, then i tried your instructions from another post on these forums Tryinng to run trackball python file on boot up - #8 by alphanumeric, just checked my os and its Bullseye, so i presume thats the reason im having trouble?.

I’m thinking Bullseye is part of the issue. Running sudo ./ gets me an evdev error. And if I manually install evdev I get a modprob error. I think it was modprob?

Forgot all about that other thread, will have to have a look at it to see what I did then. works for me and I may just try loading it on bootup with crontab, and see it that works this time around.

Hi, yeah i was getting same error (evdev), thanks for you help

I’ll confirm latter, but I think what I did was edit the file.
and changed
sudo apt install python-evdev
sudo apt install python3-evdev

That was the edit I made. I’m going backwards now though, was working (even after that edit) but fails now with a chip ID error. Something like that? i2cdetect is showing the right address though? Looks like I have it really messed up now?

Thanks I will try that, sorry you have messed up yours trying to help.

Looks like my latest issue is because I didn’t wire up the INT pin. If I jumper that pin works. It was plugged into my Breakout Garden, and worked Ok. Stopped working when I soldered it to a Proto Zero. Going to be a PITA to fix this now that’s its soldered in place. It would have happened anyway, regardless. Live and learn.

Got it working. worked once i wired up the INT pin.
And adding the following via sudo crontab -e
@reboot python3 /home/pi/trackball-python/examples/ &
Gets it working on boot up.

Thanks I’ll have a look the weekend as I’m away from home at the moment, I’ll let you know how I get on.

Any progress on Bullseye?