Drum Hat pad not as sensitive [SOLVED]


#1

I got my Drum Hat set up last night with the code from the github page. It works great except I need to press a bit harder for the upper left pad (the one with a 7 on it).

Is this normal? All the other ones I just need to brush my finger past but that one I need to press done hard like a button.


#2

Did you plug in your Drum HAT while your Pi was powered on? And were you holding it from this corner?

It does some auto-calibration on power up which will set the “normal” levels for the capacitance of a pad. If you happen to be holding a pad when you plug it in, this exact problem will occur. I’ve been meaning to add a re-calibrate step into the library when it first starts up to mitigate this.

Try power cycling your Pi- shut it down, unplug it, and plug it back in again, and hopefully it’ll be right as rain. Just avoid touching the drum pads when you do :D


#3

I may have been, I was switching between hats when setting it up. I will try that out tonight


#4

I must have been touching that corner when I put the hat on.I just tried again with it on before turning my Pi on and it works perfect. Thanks for the help!


#5

You’re welcome! I’ve done it to myself a few times with various cap-touch thingamees!