Faulty OnOff-Shim?


#1

Soldered the OnOff-Shim to the header. Soldered a momentary button to the board.

Attached the Shim to a Pi 3 and attached power.

If I press and hold either button, the Pi will start.

As soon as I let go of either button, the power is immediately cut to the Pi.

Did I get a faulty unit?


#2

I had a very similar issue with the shim on the first one I assembled (see here which didn’t get any response: Pi onoff shim loses power after a few seconds )

I assumed it was a soldering issue and purchased another one to try again (which i ended up destroying along with a pi zero w as I forgot to unplug power when i tried tidying up one of the solder joints on the header with the soldering iron = kzzzrt pop!)

however recently I looked at the first one again and I noticed one of the tiny board mounted components was actually loose on one side and had been twisted round 45 degrees. so that one ended up going in the bin as well.

third time turned out to be the charm and finally got one working when I assembled my project on a black hat hack3r pcb with a cut down male header with just the shim pins needed and only soldered onto the pins required to make it work.

now it works flawlessly but i get the feeling it was more luck than anything else as it’s quite a tricky thing to install as soldering to header pins is not easy to do well for beginners.


#3

!!

I hope we replaced that!

General things to check:

  • Make sure the soldering is tidy and there are no bridges
  • Make sure the power is plugged into OnOff SHiM not the Pi (sounds obvious, but you never know)

#4

@gadgetoid I couldn’t tell if i’d maybe knocked it when soldering or not so I didnt bother with an rma as was willing to assume it was probably my fault as I’m still pretty cack-handed with a soldering iron.


#5

Thanks for your suggestions.

I should have mentioned that my son who works at a electronics manufacturing firm did the soldering. He has the skill to build these boards so I doubt the soldering is the issue.

Was hoping for a engineering solution. This chip in this location may be bad/disconnected. While I am not comfortable asking my son to troubleshoot the whole board, I would ask him to look at a limited number of chips or connections.

Again, as long as I hold down the button, power is supplied to the Pi. As soon as I let up on the button, power is lost.


#6

I have already tried 2 of these shims and both have the same result as above. I have another 4 unsoldered but am not too enthusiastic about them. I think I will send them all back.