Fingerprint Sensor GT-511C1R Help


#1

Hi

I’m hoping someone can help me. I am having trouble getting the Fingerprint sensor GT-511C1R working with my Arduino Uno.

It was working until earlier today but has now stopped responding.

I was able to use the test example sketches to get the LED to blink and also able to register and recognise a fingerprint. Whilst running through the enrol sketch for the second time I was getting an error as it couldn’t see a fingerprint. Now for some reason even the blink sketch isn’t working.

When going into the serial monitor the text below is printed:

FPS - Open
FPS - SEND: “55 AA 01 00 00 00 00 00 01 00 01 01”

This is where it hangs. There should be a third line where it receives a response. This is the exact issue I had with the first device I received which was replaced. This second device worked great until now, around 2 weeks, and the same has now happened.

It is connected correctly with the supply being 5V DC as instructed and the TX RX going through a voltage divider to bring the voltage down to 3.2V.

If anyone can help, or if a moderator could give any advice to try I would appreciate it. This is part of my BEng Hons Dissertation project which I only have a week left on, so my back is up against the wall a little.

Thanks in advance

Kev


#2

Updated and resolved.

Thanks to Matt from Pimoroni for his help in replacing the unit the next day for me.

The new unit still wouldn’t work so I searched further and found the following link:

This states that the voltage divider on the TX and RX is NOT required. I tried this and it worked perfectly. This is despite all the test sketches and instructables pages saying it is required.

Really happy now,

Thanks again

Kev