Adafruit Gemma neopixel ring arduino


#1

Can anybody tell me why a gemma that has been connected successfully start not showing it’s red bootloader light when you plug it into the exact same usb that it was working in? I ended up getting a new gemma and when that was plugged into the same usb it connected just like the first one originally did.

I’ve ended up ordering another to replace the first but there’s power to it so I thought it was saveable.

Any ideas please?


#2

Probably best to ask that on the Adafruit forums - it’s possibly a hardware fault or a corrupted bootloader, they have more insight! http://forums.adafruit.com/viewforum.php?f=51


#3

Thanks for the reply. I had posted on the adafruit forum but no reply. Then I saw they said that they only support their own customers. I wondered if they meant customers who had directly bought from them as mine were via you. Anyway I’ve ordered another now but I was trying to resurrect it. To be honest I’m not having much luck with it all so would be keen to find somebody else who has used the little trouble makers.


#4

if is worked earlier I would put a penny or 2 (I’m a cautious gambler!) on a scrambled firmware. Have you tried reflashing it?


#5

I’m a beginner. How do I reflash it please?
Windows isn’t recognising this gemma. It recognises my other, so I’ve got the drivers on etc.

To be honest it’s not the end of the world as I’ve ordered another.

I’m more concerned that I’ve been unable to get anything working so far!

I am trying to make this:

I have just put the code on as it is here. Should I have changed it?

When I tested with the blink I just ran it as it was and it turned out I had to change the number for the pin so I’m wondering if I should change any of this.

I’ve never done arduino before in my life I’m just trying to help my daughter with something for school. I thought it would be simple but it’s driving me nuts. It doesn’t matter really what the ring does, it just needs to light up etc etc. It’s to go on a bag she’s designed based on the solar system and this bit is for the sun.

One pixel lit up and that’s it. Now nothing. I’m wondering if this ring is shot. I’ve ordered another…aaaargh

Any help or advise appreciated.


#6

arduino boards are extremely resillient, you’d be hard pushed to kill them for good, but it’s possible to corrupt the bootloader, or flash them with code that has no apparent effect or that affects communication with the host.

Reflashing a bootloader requires a hardware programmer, or a suitable arduino board. I suspect you don’t have either at hand?

If you can return the troublesome gemma I’m happy to have a look. If it’s not dead, I can return it pre-burnt with the program you linked to if that’s any use to you, i.e your deadlne has not passed.


#7

That sounds like a master plan, thank you. However, I’ve put that code on my second gemma and it’s not working. Do you think I should have changed the code?

I’ve got a daft question…when you download the code to the gemma are you supposed to clear it inbetween etc? I assumed any new code would override anything previously put on??


#8

Hang on…the language you used in your last post ‘pre burned’ has made me think…(with my second gemma and ring)…

In arduino I clicked the tick to verify - ok
Then I clicked the arrow next to it to upload to the gemma - ok
Was I supposed to do anything after that?

I’ve just seen under tools it says ‘burn bootlader’. Am I supposed to do something with that? I assumed it was done after the download cos the blink worked.


#9

burn and flash are interchangeable words… well, they are to me, though I can see where I would have introduced confusion.

You seem to be doing things correctly (you don’t have to ‘verify’ the code first, but it’s a good habit).

Several things that come to mind though:

  • have you wired the neopixels to D0? I suspect so otherwise none of them would light up.

  • what size is the ring and how are you powering it? It’s possible the USB port on your computer is not able to supply enough power, so make sure to disconnect the board and power from a lipo, or other suitable source to test the result.


#10

None of the ring pixels are lighting up anymore. It was just for a short while that one came on.
16 ring
two cr32 batteries and a holder that came in the starter kit

photo links:
https://drive.google.com/file/d/0B-oBoD5xJkQYalhXWHlwdlkxc1k/view?usp=sharing

https://drive.google.com/file/d/0B-oBoD5xJkQYZEI4RHZEWnQ1cUE/view?usp=sharing


#11

hum, in fact I could totally see that as a potential cause for scrambling a bootloader.

What I might recommend if the neopixels are hooked up to the gemma is to decouple VCC (or ground) to it while you are uploading code as a safety measure. Easier said than done if you soldered the landings.


#12

To clarify:

The gemma in the ring set up is my second gemma that connects via usb fine and took the code. It’s just the ring that won’t come on.

I gave up on the first gemma.


#13

is the red LED flashing or steady? either way I can’t see anything in the code that would trigger it and I suspect it should not be lit during operation. Meaning, I suspect you still got another program loaded up, or it is stuck in bootloader mode.

I’ll have a look at the neopixel lib and see if I can find a way to test the ring functionality that is a bit easier to troubleshoot.


#14

in fact re-reading the Adafruit documentation I’m wondering if your ‘dead’ gemma board is not simply already programmed (with no visible effect) and as such the bootloader ‘D1’ LED will not pulse when connected to the host PC.

… don’t quote me on that as I’ve not toyed around with a Gemma board before, but that’s what I infer from the standard procedure described to program them. Have you tried to program it again after pressing the reset button?


#15

Dead gemma is no longer seen by usb. It lights up the green onboard led but not the red one. Pressing the reset button does nothing. It didn’t arrive like that, but went like that last night. I had previously put code on it. I got the blink to work on it etc. It went like that when I was trying to put different code on it. It’s never been soldered or anything.

With the gemmas, pressing the reset button starts the onboard red led flashing and that’s when the bootloader is working and when you download the code. So, with that bit no longer working, I can’t do anything with it.

Question…
When you download the code to the gemma are you supposed to clear it inbetween etc? I assumed any new code would override anything previously put on??


#16

On new gemma with ring…
When I turn it on the green onboard led lights up and so does the red onboard led (but not brightly like when connected to usb and in bootloader mode)…then then after a couple of seconds the red goes out for a second and comes back on for 2secs etc etc

No lights on the ring are lighting up at all.


#17

could it be you flashed the blink code instead (using pin 1)… I may be barking the wrong tree but it should not be active at all, unless you changed the code to pass data/signal through pin 1 instead of pin 0.


#18

New gemma with ring:


#19

I just used the code as it is in the tutorial.

I’ve since tried a different code for the ring, but still no result.

I’ve put the original code back on and it is still the same.

I wondered if it was the power, so I have changed my 2x cr32 battery pack for one of these: https://www.pi-supply.com/product/lithium-ion-polymer-battery-3-7v-150mah/?v=79cba1185463

Same result.


#20

it’s hard to tell without being in front of the IDE but it certainly does not look like the code on the chip is the right one based on your video. Is there definitely a confirmation that the uploading was successful?

I just noted you asked a couple of times and I did not confirm, but yes, new programs/sketches you would upload successfully would overwrite the previous routine. The red LED is on D1 i.e pin 1 so I really have no explanation why it would light up in your video after flashing the hoop earings code.