Flotilla - Mega Treasure Chest Starter Kit


#1

Dear Support,

I got to play with this kit over Christmas and while most of it worked fine I ran into a number of problems. These were:

Bat n Ball recipe:
System says it cannot find the Dial so will not start. The dial works on other recipes and the lights illuminate as you turn it.

Marble Maze recipe:
Motion module is attached and can be found but does not appear to give an output so it does not work.

Reaction Time recipe:
I struggled to get this to work at all. Everything was found but feedback from touch module appeared to be slow / non-existent. No times were recorded.

Music Synth recipe:
This appears to work but I cannot get any sound.

Can you please advise how these issues can be resolved?

Stuart.


#2

Hi,

Sorry to hear you’re having a rough time with Flotilla. I’ll have to look over these Cookbook recipes to see what might be up.

In order to help me replicate your problem, what type of computer were you running them on, and in what browser?

Thank you!


#3

Hi Phil,

I am using a Raspberry Pi and the native browser.

Stuart


#4

Okay, I’ll have to test on a Pi. It worked from my desktop, but it’s possible there’s some bug that only manifests in the Pi browser I’ve missed.

By native; do you know if it’s Epiphany or Chromium?


#5

Hi, the browser is the default Epiphany (web).


#6

Do you know what version of Raspbian you’re running? You can normally find out by running lsb_release -a in the Terminal.

You should probably grab the latest version of Raspbian, since the Pi has moved on from Epiphany to Chromium now- https://www.raspberrypi.org/downloads/raspbian/

It might be possible to just install the new browser, via: sudo apt install chromium

Unfortunately Epiphany is pretty crusty now, and not only lacks a number of features needed by Flotilla, but makes it really hard to debug when something goes awry. We should explain this better in our documentation!